summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-19 18:55:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-19 18:55:41 +0000
commit60f273e69fbec028a7c5440b75d9fa980dbfde76 (patch)
tree4c12ce90f98bd4cdb5262b783394622eaa925503
parentImprove some code (bug #281308). (diff)
downloadeselect-python-60f273e69fbec028a7c5440b75d9fa980dbfde76.tar.gz
eselect-python-60f273e69fbec028a7c5440b75d9fa980dbfde76.tar.bz2
eselect-python-60f273e69fbec028a7c5440b75d9fa980dbfde76.zip
Add build system.
-rw-r--r--Makefile.in10
-rwxr-xr-xautogen.sh7
-rw-r--r--configure.ac12
3 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
new file mode 100644
index 0000000..c617486
--- /dev/null
+++ b/Makefile.in
@@ -0,0 +1,10 @@
+CC = @CC@
+WARNINGS_FLAGS = -Wall -Wextra
+
+all: python-wrapper
+
+python-wrapper: config.h python-wrapper.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(WARNINGS_FLAGS) $(ASFLAGS) $(LDFLAGS) -o $@ $<
+
+clean:
+ rm -fr config.h config.h.in config.log config.status configure Makefile python-wrapper
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 0000000..b7ee211
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+"${AUTOHEADER:-autoheader}" || exit 1
+"${AUTOCONF:-autoconf}" || exit 1
+
+# Remove Autoconf cache.
+rm -fr autom4te.cache
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8aaf1b8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,12 @@
+AC_INIT([eselect-python], [20090920])
+
+AC_PROG_CC
+
+# strndup() was introduced in POSIX.1-2008.
+AC_CHECK_FUNCS([strndup])
+
+# Create output files.
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT