summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-04-26 22:28:10 +0200
committerChristian Ruppert <idl0r@gentoo.org>2010-04-26 22:28:10 +0200
commitf341d07e25a5420eeca00d713fe28d672930407f (patch)
treef666cc988e789f335df392267cbcad573db869c3
parentInitial commit. (diff)
downloadfifo-cronolog-f341d07e25a5420eeca00d713fe28d672930407f.tar.gz
fifo-cronolog-f341d07e25a5420eeca00d713fe28d672930407f.tar.bz2
fifo-cronolog-f341d07e25a5420eeca00d713fe28d672930407f.zip
Improve Makefile
Add compile target. Add vim modeline.
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 1e50259..e6a5f5e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,8 +2,13 @@ CFLAGS += -Wall
all: squid-cronolog
-squid-cronolog: squid-cronolog.c
- $(CC) $(CFLAGS) -o squid-cronolog squid-cronolog.c
+squid-cronolog: squid-cronolog.o
+ $(CC) $(LDFLAGS) -o $@ $<
+
+squid-cronolog.o: squid-cronolog.c
+ $(CC) $(CFLAGS) -c -o $@ $<
clean:
- $(RM) squid-cronolog
+ $(RM) squid-cronolog{,.o}
+
+# vim: set ts=4 sw=4 tw=80: