summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 1e50259..e6a5f5e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,8 +2,13 @@ CFLAGS += -Wall
all: squid-cronolog
-squid-cronolog: squid-cronolog.c
- $(CC) $(CFLAGS) -o squid-cronolog squid-cronolog.c
+squid-cronolog: squid-cronolog.o
+ $(CC) $(LDFLAGS) -o $@ $<
+
+squid-cronolog.o: squid-cronolog.c
+ $(CC) $(CFLAGS) -c -o $@ $<
clean:
- $(RM) squid-cronolog
+ $(RM) squid-cronolog{,.o}
+
+# vim: set ts=4 sw=4 tw=80: