aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-12-18 15:12:22 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-12-18 15:12:22 -0200
commitafc7e3f5b1a2a227e696d5e8a7860bbb151bee94 (patch)
tree757e423d08d1653933464bb8666a2395f0e41f60 /tests/files
parentrewrote DescriptionTree, as a list of Description objects (diff)
downloadg-octave-afc7e3f5b1a2a227e696d5e8a7860bbb151bee94.tar.gz
g-octave-afc7e3f5b1a2a227e696d5e8a7860bbb151bee94.tar.bz2
g-octave-afc7e3f5b1a2a227e696d5e8a7860bbb151bee94.zip
rewrote g_octave.ebuild. fixed eclass and tests
Diffstat (limited to 'tests/files')
-rw-r--r--tests/files/ebuilds/extra1-0.0.1.ebuild16
-rw-r--r--tests/files/ebuilds/extra2-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/language1-0.0.1.ebuild16
-rw-r--r--tests/files/ebuilds/language2-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/main1-0.0.1.ebuild16
-rw-r--r--tests/files/ebuilds/main2-0.0.1.ebuild9
6 files changed, 33 insertions, 42 deletions
diff --git a/tests/files/ebuilds/extra1-0.0.1.ebuild b/tests/files/ebuilds/extra1-0.0.1.ebuild
index 9e67791..e80713d 100644
--- a/tests/files/ebuilds/extra1-0.0.1.ebuild
+++ b/tests/files/ebuilds/extra1-0.0.1.ebuild
@@ -3,10 +3,9 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="extra"
-inherit g-octave eutils
+inherit g-octave
DESCRIPTION="This is the Extra 1 description"
HOMEPAGE="http://extra1.org"
@@ -16,15 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg4-1.0.0
+DEPEND=">=sci-mathematics/octave-3.2.0
+ >sci-mathematics/pkg4-1.0.0
sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
>=sci-mathematics/pkg1-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.2.0"
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/001_extra1-0.0.1.patch"
- epatch "${FILESDIR}/002_extra1-0.0.1.patch"
- g-octave_src_prepare
-}
+PATCHES=( "${FILESDIR}/001_extra1-0.0.1.patch"
+ "${FILESDIR}/002_extra1-0.0.1.patch" )
diff --git a/tests/files/ebuilds/extra2-0.0.1.ebuild b/tests/files/ebuilds/extra2-0.0.1.ebuild
index 168e9ed..8ced084 100644
--- a/tests/files/ebuilds/extra2-0.0.1.ebuild
+++ b/tests/files/ebuilds/extra2-0.0.1.ebuild
@@ -3,7 +3,6 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="extra"
inherit g-octave
@@ -16,9 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg8-1.0.0
+DEPEND=">=sci-mathematics/octave-3.2.0
+ >sci-mathematics/pkg8-1.0.0
sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
>=sci-mathematics/pkg5-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.2.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( )
diff --git a/tests/files/ebuilds/language1-0.0.1.ebuild b/tests/files/ebuilds/language1-0.0.1.ebuild
index 8964935..4efc8ce 100644
--- a/tests/files/ebuilds/language1-0.0.1.ebuild
+++ b/tests/files/ebuilds/language1-0.0.1.ebuild
@@ -3,10 +3,9 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="language"
-inherit g-octave eutils
+inherit g-octave
DESCRIPTION="This is the Language 1 description"
HOMEPAGE="http://language1.org"
@@ -16,15 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg4-1.0.0
+DEPEND=">=sci-mathematics/octave-3.2.0
+ >sci-mathematics/pkg4-1.0.0
sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
>=sci-mathematics/pkg1-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.2.0"
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/001_language1-0.0.1.patch"
- epatch "${FILESDIR}/002_language1-0.0.1.patch"
- g-octave_src_prepare
-}
+PATCHES=( "${FILESDIR}/001_language1-0.0.1.patch"
+ "${FILESDIR}/002_language1-0.0.1.patch" )
diff --git a/tests/files/ebuilds/language2-0.0.1.ebuild b/tests/files/ebuilds/language2-0.0.1.ebuild
index d10e597..c0f0bed 100644
--- a/tests/files/ebuilds/language2-0.0.1.ebuild
+++ b/tests/files/ebuilds/language2-0.0.1.ebuild
@@ -3,7 +3,6 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="language"
inherit g-octave
@@ -16,9 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg8-1.0.0
+DEPEND=">=sci-mathematics/octave-3.2.0
+ >sci-mathematics/pkg8-1.0.0
sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
>=sci-mathematics/pkg5-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.2.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( )
diff --git a/tests/files/ebuilds/main1-0.0.1.ebuild b/tests/files/ebuilds/main1-0.0.1.ebuild
index b9e2257..e7d891e 100644
--- a/tests/files/ebuilds/main1-0.0.1.ebuild
+++ b/tests/files/ebuilds/main1-0.0.1.ebuild
@@ -3,10 +3,9 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="main"
-inherit g-octave eutils
+inherit g-octave
DESCRIPTION="This is the Main 1 description"
HOMEPAGE="http://main1.org"
@@ -16,15 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg4-1.0.0
+DEPEND=">=sci-mathematics/octave-3.0.0
+ >sci-mathematics/pkg4-1.0.0
sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
>=sci-mathematics/pkg1-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.0.0"
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/001_main1-0.0.1.patch"
- epatch "${FILESDIR}/002_main1-0.0.1.patch"
- g-octave_src_prepare
-}
+PATCHES=( "${FILESDIR}/001_main1-0.0.1.patch"
+ "${FILESDIR}/002_main1-0.0.1.patch" )
diff --git a/tests/files/ebuilds/main2-0.0.1.ebuild b/tests/files/ebuilds/main2-0.0.1.ebuild
index 3b4178a..429761c 100644
--- a/tests/files/ebuilds/main2-0.0.1.ebuild
+++ b/tests/files/ebuilds/main2-0.0.1.ebuild
@@ -3,7 +3,6 @@
# This ebuild was generated by g-octave
EAPI="3"
-
G_OCTAVE_CAT="main"
inherit g-octave
@@ -16,9 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">sci-mathematics/pkg8-1.0.0
+DEPEND=">=sci-mathematics/octave-3.2.0
+ >sci-mathematics/pkg8-1.0.0
sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
>=sci-mathematics/pkg5-4.3.2"
-RDEPEND="${DEPEND}
- >=sci-mathematics/octave-3.2.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( )