aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-18 23:12:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-18 23:12:44 +0100
commitd57df4aeea1ed512a44ab4c56543877d9ec1b04b (patch)
tree6dd6e6bbf2793563f2aa5a179f21171a47280bf6
parent7.3.0: pull in all -Werror patches from 8.2.0 (diff)
downloadgcc-patches-d57df4aeea1ed512a44ab4c56543877d9ec1b04b.tar.gz
gcc-patches-d57df4aeea1ed512a44ab4c56543877d9ec1b04b.tar.bz2
gcc-patches-d57df4aeea1ed512a44ab4c56543877d9ec1b04b.zip
6.4.0: drop assumed -lieee from -mieee-fp, backport removal of -Werror
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--6.4.0/gentoo/103_all_remove-lieee.patch47
-rw-r--r--6.4.0/gentoo/104_all_libgfortran-Werror.patch20
-rw-r--r--6.4.0/gentoo/105_all_libgomp-Werror.patch20
-rw-r--r--6.4.0/gentoo/106_all_libitm-Werror.patch19
-rw-r--r--6.4.0/gentoo/107_all_libatomic-Werror.patch19
-rw-r--r--6.4.0/gentoo/108_all_libbacktrace-Werror.patch17
-rw-r--r--6.4.0/gentoo/109_all_libsanitizer-libbacktrace-Werror.patch17
-rw-r--r--6.4.0/gentoo/README.history9
8 files changed, 168 insertions, 0 deletions
diff --git a/6.4.0/gentoo/103_all_remove-lieee.patch b/6.4.0/gentoo/103_all_remove-lieee.patch
new file mode 100644
index 0000000..390a3b0
--- /dev/null
+++ b/6.4.0/gentoo/103_all_remove-lieee.patch
@@ -0,0 +1,47 @@
+Modern glibc stopped providing ieee.a
+
+From 401a6ba8d6aa5a92acaedae24b84c59d284f446d Mon Sep 17 00:00:00 2001
+From: rguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>
+Date: Thu, 12 Jul 2018 11:53:34 +0000
+Subject: [PATCH] 2018-07-12 Richard Biener <rguenther@suse.de>
+
+ PR target/84829
+ * config/gnu-user.h (GNU_USER_TARGET_NO_PTHREADS_LIB_SPEC):
+ Remove -mieee-fp handling.
+
+ * gcc.target/i386/pr84829.c: New testcase.
+
+
+git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@262582 138bc75d-0d04-0410-961f-82ee72b054a4
+---
+ gcc/ChangeLog | 6 ++++++
+ gcc/config/gnu-user.h | 2 +-
+ gcc/testsuite/ChangeLog | 5 +++++
+ gcc/testsuite/gcc.target/i386/pr84829.c | 7 +++++++
+ 4 files changed, 19 insertions(+), 1 deletion(-)
+ create mode 100644 gcc/testsuite/gcc.target/i386/pr84829.c
+
+--- a/gcc/config/gnu-user.h
++++ b/gcc/config/gnu-user.h
+@@ -120,7 +120,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
+
+ #define GNU_USER_TARGET_NO_PTHREADS_LIB_SPEC \
+ "%{shared:-lc} \
+- %{!shared:%{mieee-fp:-lieee} %{profile:-lc_p}%{!profile:-lc}}"
++ %{!shared:%{profile:-lc_p}%{!profile:-lc}}"
+
+ #define GNU_USER_TARGET_LIB_SPEC \
+ "%{pthread:-lpthread} " \
+--- /dev/null
++++ b/gcc/testsuite/gcc.target/i386/pr84829.c
+@@ -0,0 +1,7 @@
++/* { dg-do link } */
++/* { dg-options "-mieee-fp" } */
++
++int main()
++{
++ return 0;
++}
+--
+2.19.0
+
diff --git a/6.4.0/gentoo/104_all_libgfortran-Werror.patch b/6.4.0/gentoo/104_all_libgfortran-Werror.patch
new file mode 100644
index 0000000..f6c26bf
--- /dev/null
+++ b/6.4.0/gentoo/104_all_libgfortran-Werror.patch
@@ -0,0 +1,20 @@
+libgfortran does not respect --disable-werror
+
+https://bugs.gentoo.org/433435
+http://gcc.gnu.org/PR54724
+
+
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,3 +140,3 @@ AM_PROG_CC_C_O
+ if test "x$GCC" = "xyes"; then
+- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
++ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
+ ## We like to use C11 and C99 routines when available. This makes
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -5764,3 +5764,3 @@ fi
+ # Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
++ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
diff --git a/6.4.0/gentoo/105_all_libgomp-Werror.patch b/6.4.0/gentoo/105_all_libgomp-Werror.patch
new file mode 100644
index 0000000..416808a
--- /dev/null
+++ b/6.4.0/gentoo/105_all_libgomp-Werror.patch
@@ -0,0 +1,20 @@
+libgomp does not respect --disable-werror
+
+https://bugs.gentoo.org/229059
+http://gcc.gnu.org/PR38436
+--- a/libgomp/configure.ac
++++ b/libgomp/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libgomp/configure
++++ b/libgomp/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/6.4.0/gentoo/106_all_libitm-Werror.patch b/6.4.0/gentoo/106_all_libitm-Werror.patch
new file mode 100644
index 0000000..27181e0
--- /dev/null
+++ b/6.4.0/gentoo/106_all_libitm-Werror.patch
@@ -0,0 +1,19 @@
+libitm does not respect --disable-werror
+
+https://bugs.gentoo.org/475350
+--- a/libitm/configure.ac
++++ b/libitm/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libitm/configure
++++ b/libitm/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/6.4.0/gentoo/107_all_libatomic-Werror.patch b/6.4.0/gentoo/107_all_libatomic-Werror.patch
new file mode 100644
index 0000000..0550722
--- /dev/null
+++ b/6.4.0/gentoo/107_all_libatomic-Werror.patch
@@ -0,0 +1,19 @@
+libatomic does not respect --disable-werror
+
+https://bugs.gentoo.org/475350
+--- a/libatomic/configure.ac
++++ b/libatomic/configure.ac
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+--- a/libatomic/configure
++++ b/libatomic/configure
+@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+ # Add -Wall -Werror if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
diff --git a/6.4.0/gentoo/108_all_libbacktrace-Werror.patch b/6.4.0/gentoo/108_all_libbacktrace-Werror.patch
new file mode 100644
index 0000000..57dd284
--- /dev/null
+++ b/6.4.0/gentoo/108_all_libbacktrace-Werror.patch
@@ -0,0 +1,17 @@
+libbacktrace does not respect --disable-werror
+
+https://bugs.gentoo.org/667104
+--- a/libbacktrace/configure
++++ b/libbacktrace/configure
+@@ -11634,3 +11634,3 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ WARN_FLAGS="$WARN_FLAGS"
+ fi
+--- a/libbacktrace/configure.ac
++++ b/libbacktrace/configure.ac
+@@ -138,3 +138,3 @@ ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
+ if test -n "${with_target_subdir}"; then
+- WARN_FLAGS="$WARN_FLAGS -Werror"
++ WARN_FLAGS="$WARN_FLAGS"
+ fi
diff --git a/6.4.0/gentoo/109_all_libsanitizer-libbacktrace-Werror.patch b/6.4.0/gentoo/109_all_libsanitizer-libbacktrace-Werror.patch
new file mode 100644
index 0000000..46a219a
--- /dev/null
+++ b/6.4.0/gentoo/109_all_libsanitizer-libbacktrace-Werror.patch
@@ -0,0 +1,17 @@
+libsanitizer/libbacktrace does not respect --disable-werror
+
+https://bugs.gentoo.org/667104
+--- a/libsanitizer/libbacktrace/Makefile.am
++++ b/libsanitizer/libbacktrace/Makefile.am
+@@ -37,3 +37,3 @@ AM_CPPFLAGS = -I $(top_srcdir)/../include -I $(top_srcdir)/../libgcc \
+ WARN_FLAGS = -W -Wall -Wwrite-strings -Wmissing-format-attribute \
+- -Wcast-qual -Werror
++ -Wcast-qual
+ C_WARN_FLAGS = $(WARN_FLAGS) -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition
+--- a/libsanitizer/libbacktrace/Makefile.in
++++ b/libsanitizer/libbacktrace/Makefile.in
+@@ -293,3 +293,3 @@ AM_CPPFLAGS = -I $(top_srcdir)/../include -I $(top_srcdir)/../libgcc \
+ WARN_FLAGS = -W -Wall -Wwrite-strings -Wmissing-format-attribute \
+- -Wcast-qual -Werror
++ -Wcast-qual
+
diff --git a/6.4.0/gentoo/README.history b/6.4.0/gentoo/README.history
index 5542ec0..9274752 100644
--- a/6.4.0/gentoo/README.history
+++ b/6.4.0/gentoo/README.history
@@ -1,3 +1,12 @@
+1.8 TODO
+ + 103_all_remove-lieee.patch
+ + 104_all_libgfortran-Werror.patch
+ + 105_all_libgomp-Werror.patch
+ + 106_all_libitm-Werror.patch
+ + 107_all_libatomic-Werror.patch
+ + 108_all_libbacktrace-Werror.patch
+ + 109_all_libsanitizer-libbacktrace-Werror.patch
+
1.7 23 Sep 2018
+ 101_all_x32-fix-eh-return-address.patch
+ 102_all_respect-build-cxxflags.patch