summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-01-23 14:35:48 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-01-23 14:35:48 -0800
commit860d09dc1cf3f08e8ef2caad5b11b19ae6b9fa61 (patch)
treefdbaa48592313c50b6671032b76b9eee80bc5100
parentgen_configkernel: clean up logic, and correctly fall back to non-generated kc... (diff)
downloadgenkernel-860d09dc1cf3f08e8ef2caad5b11b19ae6b9fa61.tar.gz
genkernel-860d09dc1cf3f08e8ef2caad5b11b19ae6b9fa61.tar.bz2
genkernel-860d09dc1cf3f08e8ef2caad5b11b19ae6b9fa61.zip
Improve clarity for makefile command.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0a339e36..207f7cfe 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,11 @@ distclean: clean
# Generic rules
%/generated-config: %/arch-config $(BASE_KCONF) merge.pl Makefile
- grep -sq THIS_CONFIG_IS_BROKEN $< && cat $< >$@ || grep -sq perl merge.pl $< $(BASE_KCONF) > $@
+ if grep -sq THIS_CONFIG_IS_BROKEN $< ; then \
+ cat $< >$@ ; \
+ else \
+ perl merge.pl $< $(BASE_KCONF) > $@ ; \
+ fi ;
%.8: doc/%.8.txt doc/asciidoc.conf Makefile genkernel
a2x --conf-file=doc/asciidoc.conf --attribute="genkernelversion=$(PACKAGE_VERSION)" \