aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Gaffney <agaffney@gentoo.org>2008-03-11 19:35:23 +0000
committerAndrew Gaffney <agaffney@gentoo.org>2008-03-11 19:35:23 +0000
commit182fd5e831ef1511ca7bec22397f9627cfe3e551 (patch)
tree933d00b00eaca50297b04017e655a74979593084 /patches/busybox/1.7.4
parentIt helps if we assign the correct value to version (diff)
downloadgenkernel-182fd5e831ef1511ca7bec22397f9627cfe3e551.tar.gz
genkernel-182fd5e831ef1511ca7bec22397f9627cfe3e551.tar.bz2
genkernel-182fd5e831ef1511ca7bec22397f9627cfe3e551.zip
Update mdadm and mdstart patches
git-svn-id: svn+ssh://svn.gentoo.org/var/svnroot/genkernel/trunk@620 67a159dc-881f-0410-a524-ba9dfbe2cb84
Diffstat (limited to 'patches/busybox/1.7.4')
-rw-r--r--patches/busybox/1.7.4/1.7.4-mdadm.diff78
-rw-r--r--patches/busybox/1.7.4/1.7.4-mdstart.diff6
2 files changed, 18 insertions, 66 deletions
diff --git a/patches/busybox/1.7.4/1.7.4-mdadm.diff b/patches/busybox/1.7.4/1.7.4-mdadm.diff
index 6e1932d..deb8993 100644
--- a/patches/busybox/1.7.4/1.7.4-mdadm.diff
+++ b/patches/busybox/1.7.4/1.7.4-mdadm.diff
@@ -17,7 +17,7 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/include/applets.h busybox-1.7
+++ busybox-1.7.4+gentoo+mdadm/include/applets.h 2008-03-11 10:32:22.000000000 -0700
@@ -223,2 +223,3 @@
USE_MD5SUM(APPLET_ODDNAME(md5sum, md5_sha1_sum, _BB_DIR_USR_BIN, _BB_SUID_NEVER, md5sum))
-+USE_MDADM(APPLET(mdadm, mdadm_main, _BB_DIR_SBIN, _BB_SUID_NEVER))
++USE_MDADM(APPLET(mdadm, _BB_DIR_SBIN, _BB_SUID_NEVER))
USE_MDEV(APPLET(mdev, _BB_DIR_SBIN, _BB_SUID_NEVER))
diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/include/usage.h busybox-1.7.4+gentoo+mdadm/include/usage.h
--- busybox-1.7.4+gentoo/include/usage.h 2008-03-11 10:19:04.000000000 -0700
@@ -1171,7 +1171,7 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/Config.in busybox-1.7.4
+
+menu "Linux mdadm Utilities"
+
-+config CONFIG_MDADM
++config MDADM
+ bool "mdadm"
+ default n
+ help
@@ -1291,68 +1291,6 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/dlink.h busybox-1.7.4+g
+void dl_del(void*);
+void dl_free(void*);
+void dl_init(void*);
-diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/Makefile busybox-1.7.4+gentoo+mdadm/mdadm/Makefile
---- busybox-1.7.4+gentoo/mdadm/Makefile 1969-12-31 16:00:00.000000000 -0800
-+++ busybox-1.7.4+gentoo+mdadm/mdadm/Makefile 2008-03-11 10:31:00.000000000 -0700
-@@ -0,0 +1,23 @@
-+# Makefile for busybox
-+#
-+# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
-+#
-+# Licensed under the GPL v2, see the file LICENSE in this tarball.
-+
-+ifndef top_srcdir
-+top_srcdir=..
-+endif
-+ifndef top_builddir
-+top_builddir=..
-+endif
-+srcdir=$(top_srcdir)/mdadm
-+MDADM_DIR:=./
-+include $(top_builddir)/Rules.mak
-+include $(top_builddir)/.config
-+include Makefile.in
-+all: $(libraries-y)
-+-include $(top_builddir)/.depend
-+
-+clean:
-+ rm -f *.o *.a $(AR_TARGET)
-+
-diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/Makefile.in busybox-1.7.4+gentoo+mdadm/mdadm/Makefile.in
---- busybox-1.7.4+gentoo/mdadm/Makefile.in 1969-12-31 16:00:00.000000000 -0800
-+++ busybox-1.7.4+gentoo+mdadm/mdadm/Makefile.in 2008-03-11 10:31:00.000000000 -0700
-@@ -0,0 +1,31 @@
-+# Makefile for busybox
-+#
-+# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
-+#
-+# Licensed under the GPL v2, see the file LICENSE in this tarball.
-+
-+MDADM_AR:=mdadm.a
-+ifndef $(MDADM_DIR)
-+MDADM_DIR:=$(top_builddir)/mdadm/
-+endif
-+srcdir=$(top_srcdir)/mdadm
-+
-+MDADM-y:= config.o util.o dlink.o sha1.o super0.o super1.o mdexamine.o mdassemble.o
-+MDADM-$(CONFIG_MDADM) += mdadm.o
-+
-+MDADM_SRC-y:=$(patsubst %.o,$(srcdir)/%.c,$(MDADM-y))
-+MDADM_SRC-a:=$(wildcard $(srcdir)/*.c)
-+APPLET_SRC-y+=$(MDADM_SRC-y)
-+APPLET_SRC-a+=$(MDADM_SRC-a)
-+
-+MDADM-y:=$(sort $(MDADM-y))
-+
-+ifneq ($(strip $(MDADM-y)),)
-+libraries-y+=$(MDADM_DIR)$(MDADM_AR)
-+endif
-+
-+$(MDADM_DIR)$(MDADM_AR): $(patsubst %,$(MDADM_DIR)%, $(MDADM-y))
-+ $(do_ar)
-+
-+$(MDADM_DIR)%.o: $(srcdir)/%.c
-+ $(compile.c)
diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/md5.h busybox-1.7.4+gentoo+mdadm/mdadm/md5.h
--- busybox-1.7.4+gentoo/mdadm/md5.h 1969-12-31 16:00:00.000000000 -0800
+++ busybox-1.7.4+gentoo+mdadm/mdadm/md5.h 2008-03-11 10:31:00.000000000 -0700
@@ -5930,3 +5868,15 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4+gentoo/mdadm/util.c busybox-1.7.4+ge
+ *sizep = ldsize;
+ return 1;
+}
+--- busybox-1.7.4+gentoo/mdadm/Kbuild 2008-03-01 18:44:05.526713152 -0800
++++ busybox-1.7.4+gentoo+mdadm/mdadm/Kbuild 2008-03-11 12:19:18.000000000 -0700
+@@ -0,0 +1,9 @@
++# Makefile for busybox
++#
++# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
++#
++# Licensed under the GPL v2, see the file LICENSE in this tarball.
++
++lib-y:=
++MDADM-y:= config.o util.o dlink.o sha1.o super0.o super1.o mdexamine.o mdassemble.o
++lib-$(CONFIG_MDADM) += mdadm.o $(MDADM-y)
diff --git a/patches/busybox/1.7.4/1.7.4-mdstart.diff b/patches/busybox/1.7.4/1.7.4-mdstart.diff
index c13670d..c6a9d6d 100644
--- a/patches/busybox/1.7.4/1.7.4-mdstart.diff
+++ b/patches/busybox/1.7.4/1.7.4-mdstart.diff
@@ -17,12 +17,14 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4/include/applets.h busybox-1.7.4+gent
diff -Nuar --exclude '*.orig' busybox-1.7.4/include/usage.h busybox-1.7.4+gentoo/include/usage.h
--- busybox-1.7.4/include/usage.h 2007-09-03 04:48:46.000000000 -0700
+++ busybox-1.7.4+gentoo/include/usage.h 2008-03-11 10:19:04.000000000 -0700
-@@ -2072,6 +2072,9 @@
+@@ -2072,6 +2072,11 @@
"the last line match .* to override this.)\n\n" \
)
+#define mdstart_trivial_usage \
+ "{[PARTITION] MD-NODE}..."
++#define mdstart_full_usage \
++ "Run the RAID_AUTORUN ioctl on the given MD number"
+
#define mesg_trivial_usage \
"[y|n]"
@@ -34,7 +36,7 @@ diff -Nuar --exclude '*.orig' busybox-1.7.4/util-linux/Config.in busybox-1.7.4+g
/lib/firmware/ and if it exists, send it to the kernel for
loading into the hardware.
-+config CONFIG_MDSTART
++config MDSTART
+ bool "mdstart"
+ default n
+ help