aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2010-11-29 10:26:58 +0100
committerSebastian Pipping <sebastian@pipping.org>2010-11-29 10:26:58 +0100
commite9768b0b2b025da6bafe7a667f791dcdf4a11656 (patch)
tree801f80de14e23020cd469eddd12412dbe1a7c20d /patches/busybox
parentApply patches from Gentoo bug #268468 (diff)
downloadgenkernel-e9768b0b2b025da6bafe7a667f791dcdf4a11656.tar.gz
genkernel-e9768b0b2b025da6bafe7a667f791dcdf4a11656.tar.bz2
genkernel-e9768b0b2b025da6bafe7a667f791dcdf4a11656.zip
Add patch allowing compilation of busybox 1.7.4 with make 3.82 (bug #341943)
Diffstat (limited to 'patches/busybox')
-rw-r--r--patches/busybox/1.7.4/1.7.4-make-3.82.diff42
1 files changed, 42 insertions, 0 deletions
diff --git a/patches/busybox/1.7.4/1.7.4-make-3.82.diff b/patches/busybox/1.7.4/1.7.4-make-3.82.diff
new file mode 100644
index 0000000..0559761
--- /dev/null
+++ b/patches/busybox/1.7.4/1.7.4-make-3.82.diff
@@ -0,0 +1,42 @@
+From d508d972c7f808eec5139255f661d37817c79260 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 29 Nov 2010 09:52:22 +0100
+Subject: [PATCH] Split implicit and normal rules for make 3.82
+
+---
+ Makefile | 12 ++++++++++--
+ 1 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c1fe21b..a2bfe4b 100644
+--- Makefile
++++ Makefile
+@@ -402,7 +402,12 @@ ifeq ($(config-targets),1)
+ -include $(srctree)/arch/$(ARCH)/Makefile
+ export KBUILD_DEFCONFIG
+
+-config %config: scripts_basic outputmakefile FORCE
++config: scripts_basic outputmakefile FORCE
++ $(Q)mkdir -p include
++ $(Q)$(MAKE) $(build)=scripts/kconfig $@
++ $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
++
++%config: scripts_basic outputmakefile FORCE
+ $(Q)mkdir -p include
+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
+ $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
+@@ -1239,7 +1244,10 @@ endif
+ $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
+
+ # Modules
+-/ %/: prepare scripts FORCE
++/: prepare scripts FORCE
++ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
++ $(build)=$(build-dir)
++%/: prepare scripts FORCE
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir)
+ %.ko: prepare scripts FORCE
+--
+1.7.3.2
+