summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-05-05 03:09:34 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-05-05 03:09:34 +0000
commit2a32df8538f5e1ac64f3bfbc3274250372fc7162 (patch)
tree9f061b39398a433b16c17c60cdb565d93471da6e /Makefile
parentactually add our new repoman completion to the distfile (diff)
downloadgentoo-bashcomp-2a32df8538f5e1ac64f3bfbc3274250372fc7162.tar.gz
gentoo-bashcomp-2a32df8538f5e1ac64f3bfbc3274250372fc7162.tar.bz2
gentoo-bashcomp-2a32df8538f5e1ac64f3bfbc3274250372fc7162.zip
Add tag target to Makefile for maintenence ease
svn path=/trunk/; revision=81
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 57d0d22..8fe1c7e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
# anything to build.
distapp = gentoo-bashcomp
-distver := $(shell date --iso | sed -e 's~-~~g')
+distver := $(shell date +%Y%m%d)
distpkg := $(distapp)-$(distver)
PREFIX = /usr
@@ -17,7 +17,14 @@ install:
ln -snf "../..$(PREFIX)/share/bash-completion/gentoo" \
"$(DESTDIR)/etc/bash_completion.d/gentoo"
-dist:
+tag:
+ svn up
+ svn cp ../trunk ../tags/tag-$(distver)
+ @echo
+ @echo "tag created remember to check it in"
+ @echo
+
+dist: tag
mkdir -p "$(distpkg)"
cp AUTHORS COPYING gentoo repoman Makefile TODO "$(distpkg)/"
svn up