summaryrefslogtreecommitdiff
path: root/gentoo
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-13 02:13:32 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-13 02:13:32 +0000
commit6dad0e44bdb346f8f4fb0d0776e4bb45c6004dfb (patch)
tree51c7401ec10425c3ac9d433cb30c270654864502 /gentoo
parentAdd layman to the Makefile (diff)
downloadgentoo-bashcomp-6dad0e44bdb346f8f4fb0d0776e4bb45c6004dfb.tar.gz
gentoo-bashcomp-6dad0e44bdb346f8f4fb0d0776e4bb45c6004dfb.tar.bz2
gentoo-bashcomp-6dad0e44bdb346f8f4fb0d0776e4bb45c6004dfb.zip
add missing ebuild options to ebuild(1) completion, bug 270560
svn path=/trunk/; revision=90
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo8
1 files changed, 4 insertions, 4 deletions
diff --git a/gentoo b/gentoo
index a6a0c83..54ef40f 100644
--- a/gentoo
+++ b/gentoo
@@ -706,11 +706,11 @@ _ebuild()
if [[ $COMP_CWORD -eq 1 ]] ; then
COMPREPLY=($(compgen -f -X "!*.ebuild" -- ${cur}) \
$(compgen -d -- ${cur}) \
- $(compgen -W '--debug --force' -- ${cur}))
-
- elif [[ $COMP_CWORD -eq 2 && "${COMP_WORDS[1]}" = "--debug --force" ]] ; then
+ $(compgen -W '--debug --force --help --ignore-default-opts --skip-manifest' -- ${cur}))
+
+ elif [[ $COMP_CWORD -eq 2 && "${COMP_WORDS[1]}" = "--debug --force --ignore-default-opts --skip-manifest" ]] ; then
COMPREPLY=($(compgen -f -X "!*.ebuild" -- ${cur}) $(compgen -d -- ${cur}))
-
+
elif [[ $COMP_CWORD -ge 2 ]] ; then
COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
fi