aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-09-10 16:56:36 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-09-10 16:56:36 -0700
commitfb4611d86c0e754fa44fa532e71597fa6d4605cb (patch)
tree2bf6d9ef9883cc0260185a2c094ce769c8e6c440
parentMatch file_write permissions. (diff)
parentBug 1398100 - tiny tweaks to release notes (diff)
downloadgentoo-bugzilla-fb4611d86c0e754fa44fa532e71597fa6d4605cb.zip
gentoo-bugzilla-fb4611d86c0e754fa44fa532e71597fa6d4605cb.tar.gz
gentoo-bugzilla-fb4611d86c0e754fa44fa532e71597fa6d4605cb.tar.bz2
Merge remote-tracking branch 'upstream/5.0'
-rw-r--r--Bugzilla/Constants.pm2
-rw-r--r--Bugzilla/DB/Sqlite.pm1
-rw-r--r--Bugzilla/Install/Filesystem.pm17
-rw-r--r--Bugzilla/Migrate.pm2
-rw-r--r--Bugzilla/Util.pm2
-rw-r--r--docs/en/rst/conf.py4
-rw-r--r--docs/en/rst/installing/linux.rst2
-rw-r--r--docs/en/rst/installing/mac-os-x.rst2
-rw-r--r--docs/en/rst/installing/migrating-from-2.inc.rst2
-rw-r--r--docs/en/rst/installing/migrating.rst3
-rw-r--r--docs/en/rst/installing/quick-start.rst2
-rw-r--r--docs/en/rst/installing/upgrading-with-git.rst12
-rw-r--r--docs/en/rst/installing/windows.rst2
-rw-r--r--docs/en/rst/integrating/extensions.rst8
-rw-r--r--docs/en/rst/integrating/skins.rst2
-rwxr-xr-xeditflagtypes.cgi2
-rw-r--r--taskgraph.json36
-rw-r--r--template/en/default/pages/release-notes.html.tmpl3
18 files changed, 59 insertions, 45 deletions
diff --git a/Bugzilla/Constants.pm b/Bugzilla/Constants.pm
index b15d9b5..2d41444 100644
--- a/Bugzilla/Constants.pm
+++ b/Bugzilla/Constants.pm
@@ -200,7 +200,7 @@ use Memoize;
# CONSTANTS
#
# Bugzilla version
-use constant BUGZILLA_VERSION => "5.0.3";
+use constant BUGZILLA_VERSION => "5.0.3+";
# A base link to the current REST Documentation. We place it here
# as it will need to be updated to whatever the current release is.
diff --git a/Bugzilla/DB/Sqlite.pm b/Bugzilla/DB/Sqlite.pm
index ddafc16..a56ed31 100644
--- a/Bugzilla/DB/Sqlite.pm
+++ b/Bugzilla/DB/Sqlite.pm
@@ -219,6 +219,7 @@ sub sql_date_format {
my ($self, $date, $format) = @_;
$format = "%Y.%m.%d %H:%M:%S" if !$format;
$format =~ s/\%i/\%M/g;
+ $format =~ s/\%s/\%S/g;
return "STRFTIME(" . $self->quote($format) . ", $date)";
}
diff --git a/Bugzilla/Install/Filesystem.pm b/Bugzilla/Install/Filesystem.pm
index ca7b251..a96fd59 100644
--- a/Bugzilla/Install/Filesystem.pm
+++ b/Bugzilla/Install/Filesystem.pm
@@ -781,22 +781,21 @@ sub _update_old_charts {
# to product IDs.
sub _update_old_mining_filenames {
my ($miningdir) = @_;
+ my $dbh = Bugzilla->dbh;
my @conversion_errors;
- require Bugzilla::Product;
-
# We use a dummy product instance with ID 0, representing all products
my $product_all = {id => 0, name => '-All-'};
- bless($product_all, 'Bugzilla::Product');
print "Updating old charting data file names...";
- my @products = Bugzilla::Product->get_all();
+ my @products = @{ $dbh->selectall_arrayref('SELECT id, name FROM products
+ ORDER BY name', {Slice=>{}}) };
push(@products, $product_all);
foreach my $product (@products) {
- if (-e File::Spec->catfile($miningdir, $product->id)) {
+ if (-e File::Spec->catfile($miningdir, $product->{id})) {
push(@conversion_errors,
{ product => $product,
- message => 'A file named "' . $product->id .
+ message => 'A file named "' . $product->{id} .
'" already exists.' });
}
}
@@ -804,8 +803,8 @@ sub _update_old_mining_filenames {
if (! @conversion_errors) {
# Renaming mining files should work now without a hitch.
foreach my $product (@products) {
- if (! rename(File::Spec->catfile($miningdir, $product->name),
- File::Spec->catfile($miningdir, $product->id))) {
+ if (! rename(File::Spec->catfile($miningdir, $product->{name}),
+ File::Spec->catfile($miningdir, $product->{id}))) {
push(@conversion_errors,
{ product => $product,
message => $! });
@@ -821,7 +820,7 @@ sub _update_old_mining_filenames {
print " FAILED:\n";
foreach my $error (@conversion_errors) {
printf "Cannot rename charting data file for product %d (%s): %s\n",
- $error->{product}->id, $error->{product}->name,
+ $error->{product}->{id}, $error->{product}->{name},
$error->{message};
}
print "You need to empty the \"$miningdir\" directory, then run\n",
diff --git a/Bugzilla/Migrate.pm b/Bugzilla/Migrate.pm
index 0731d4f..7865c84 100644
--- a/Bugzilla/Migrate.pm
+++ b/Bugzilla/Migrate.pm
@@ -403,7 +403,7 @@ sub parse_date {
}
my $tz;
if ($time[6]) {
- $tz = Bugzilla->local_timezone->offset_as_string($time[6]);
+ $tz = DateTime::TimeZone->offset_as_string($time[6]);
}
else {
$tz = $self->config('timezone');
diff --git a/Bugzilla/Util.pm b/Bugzilla/Util.pm
index a1b2513..57ce5f6 100644
--- a/Bugzilla/Util.pm
+++ b/Bugzilla/Util.pm
@@ -613,7 +613,7 @@ sub datetime_from {
second => defined($time[0]) ? int($time[0]) : undef,
# If a timezone was specified, use it. Otherwise, use the
# local timezone.
- time_zone => Bugzilla->local_timezone->offset_as_string($time[6])
+ time_zone => DateTime::TimeZone->offset_as_string($time[6])
|| Bugzilla->local_timezone,
);
diff --git a/docs/en/rst/conf.py b/docs/en/rst/conf.py
index a758fd2..34acb47 100644
--- a/docs/en/rst/conf.py
+++ b/docs/en/rst/conf.py
@@ -44,7 +44,7 @@ master_doc = 'index'
# General information about the project.
project = u'Bugzilla'
-copyright = u'2014, The Bugzilla Team'
+copyright = u'2016, The Bugzilla Team'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
@@ -387,7 +387,7 @@ todo_include_todos = False
on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
if on_rtd:
- base_api_url = 'https://www.bugzilla.org/docs/5.0/en/html/api/'
+ base_api_url = 'https://www.bugzilla.org/docs/5.0/en/html/integrating/api/'
else:
base_api_url = '../integrating/api/'
diff --git a/docs/en/rst/installing/linux.rst b/docs/en/rst/installing/linux.rst
index 22d0bf7..f40c5e8 100644
--- a/docs/en/rst/installing/linux.rst
+++ b/docs/en/rst/installing/linux.rst
@@ -117,7 +117,7 @@ Bugzilla
The best way to get Bugzilla is to check it out from git:
-:command:`git clone --branch release-X.X-stable https://git.mozilla.org/bugzilla/bugzilla`
+:command:`git clone --branch release-X.X-stable https://github.com/bugzilla/bugzilla`
Run the above command in your home directory, replacing "X.X" with the 2-digit
version number of the stable release of Bugzilla that you want - e.g. "4.4".
diff --git a/docs/en/rst/installing/mac-os-x.rst b/docs/en/rst/installing/mac-os-x.rst
index b18a5ec..37a1d36 100644
--- a/docs/en/rst/installing/mac-os-x.rst
+++ b/docs/en/rst/installing/mac-os-x.rst
@@ -28,7 +28,7 @@ Bugzilla
The best way to get Bugzilla is to check it out from git:
-:command:`git clone --branch release-X.X-stable https://git.mozilla.org/bugzilla/bugzilla`
+:command:`git clone --branch release-X.X-stable https://github.com/bugzilla/bugzilla`
Run the above command in your home directory, replacing "X.X" with the 2-digit
version number of the stable release of Bugzilla that you want - e.g. "4.4".
diff --git a/docs/en/rst/installing/migrating-from-2.inc.rst b/docs/en/rst/installing/migrating-from-2.inc.rst
index c932807..889e5c3 100644
--- a/docs/en/rst/installing/migrating-from-2.inc.rst
+++ b/docs/en/rst/installing/migrating-from-2.inc.rst
@@ -21,7 +21,7 @@ Mac OS X, you can
Once git is installed, run these commands to pull a copy of Bugzilla:
-:command:`git clone https://git.mozilla.org/bugzilla/bugzilla bugzilla-new`
+:command:`git clone https://github.com/bugzilla/bugzilla bugzilla-new`
:command:`cd bugzilla-new`
diff --git a/docs/en/rst/installing/migrating.rst b/docs/en/rst/installing/migrating.rst
index 5b842dd..8fc0de5 100644
--- a/docs/en/rst/installing/migrating.rst
+++ b/docs/en/rst/installing/migrating.rst
@@ -4,8 +4,7 @@ Migrating From Other Bug-Tracking Systems
#########################################
Bugzilla has a framework you can use for migrating from other bug-tracking
-systems -
-`Bugzilla::Migrate <http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Migrate.html>`_.
+systems - :api:`Bugzilla::Migrate <Bugzilla/Migrate.html>`.
It provides the infrastructure you will need,
but requires a module to be written to define the specifics of the system you
are coming from. One exists for
diff --git a/docs/en/rst/installing/quick-start.rst b/docs/en/rst/installing/quick-start.rst
index 64a88e5..7ea5ed5 100644
--- a/docs/en/rst/installing/quick-start.rst
+++ b/docs/en/rst/installing/quick-start.rst
@@ -64,7 +64,7 @@ Get it from our Git repository:
:command:`cd /var/www/html`
-:command:`git clone --branch release-X.X-stable https://git.mozilla.org/bugzilla/bugzilla bugzilla`
+:command:`git clone --branch release-X.X-stable https://github.com/bugzilla/bugzilla bugzilla`
(where "X.X" is the 2-digit version number of the stable release of Bugzilla
that you want - e.g. 5.0)
diff --git a/docs/en/rst/installing/upgrading-with-git.rst b/docs/en/rst/installing/upgrading-with-git.rst
index 075ff89..8559513 100644
--- a/docs/en/rst/installing/upgrading-with-git.rst
+++ b/docs/en/rst/installing/upgrading-with-git.rst
@@ -9,6 +9,18 @@ intermediate steps. There is a script named :file:`checksetup.pl` included
with Bugzilla that will automatically do all of the database migration
for you.
+Bugzilla is now hosted on Github, but we used to be hosted on git.mozilla.org.
+If you got the code from git.mozilla.org, you need to point your
+checkout at Github instead. To find out, run:
+
+:command:`git remote -v`
+
+If you see "git.mozilla.org" anywhere in the output, then run:
+
+:command:`git remote set-url origin https://github.com/bugzilla/bugzilla`
+
+This change will only ever need to be done once.
+
.. include:: upgrading-with-1.inc.rst
You can see if you have local code customizations using:
diff --git a/docs/en/rst/installing/windows.rst b/docs/en/rst/installing/windows.rst
index adc1728..e2137a9 100644
--- a/docs/en/rst/installing/windows.rst
+++ b/docs/en/rst/installing/windows.rst
@@ -40,7 +40,7 @@ Bugzilla
The best way to get Bugzilla is to check it out from git. Download and install
git from the `git website <http://git-scm.com/download>`_, and then run:
-:command:`git clone --branch release-X.X-stable https://git.mozilla.org/bugzilla/bugzilla C:\\bugzilla`
+:command:`git clone --branch release-X.X-stable https://github.com/bugzilla/bugzilla C:\\bugzilla`
where "X.X" is the 2-digit version number of the stable release of Bugzilla
that you want (e.g. 5.0).
diff --git a/docs/en/rst/integrating/extensions.rst b/docs/en/rst/integrating/extensions.rst
index 18c5341..6a3fd8d 100644
--- a/docs/en/rst/integrating/extensions.rst
+++ b/docs/en/rst/integrating/extensions.rst
@@ -11,8 +11,8 @@ versions of Bugzilla with minimal effort. We maintain a
written by other people on our wiki. You would need to
make sure that the extension in question works with your version of Bugzilla.
-Or, you can write your own extension. See the `Bugzilla Extension
-documentation <http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Extension.html>`_
+Or, you can write your own extension. See the :api:`Bugzilla Extension
+documentation <Bugzilla/Extension.html>`
for the core documentation on how to do that. It would make sense to read
the section on :ref:`templates`. There is also a sample extension in
:file:`$BUGZILLA_HOME/extensions/Example/` which gives examples of how to
@@ -183,8 +183,8 @@ bugs, except to comment and add themselves to the CC list.
Because this kind of change is such a common request, we have added a
specific hook for it that :ref:`extensions` can call. It's called
-``bug_check_can_change_field``, and it's documented `in the Hooks
-documentation <http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Hook.html#bug_check_can_change_field>`_.
+``bug_check_can_change_field``, and it's documented :api:`in the Hooks
+documentation <Bugzilla/Hook.html#bug_check_can_change_field>`.
Checking Syntax
===============
diff --git a/docs/en/rst/integrating/skins.rst b/docs/en/rst/integrating/skins.rst
index 2cd08b4..4c1d8e2 100644
--- a/docs/en/rst/integrating/skins.rst
+++ b/docs/en/rst/integrating/skins.rst
@@ -8,7 +8,7 @@ its underlying structure. It ships with two - "Classic" and "Dusk". You can
find some more listed
`on the wiki <https://wiki.mozilla.org/Bugzilla:Addons#Skins>`_, and there
are a couple more which are part of
-`bugzilla.mozilla.org <http://git.mozilla.org/?p=webtools/bmo/bugzilla.git>`_.
+`bugzilla.mozilla.org <https://github.com/mozilla-bteam/bmo>`_.
However, in each
case you may need to check that the skin supports the version of Bugzilla
you have.
diff --git a/editflagtypes.cgi b/editflagtypes.cgi
index d0b9443..71f7cb6 100755
--- a/editflagtypes.cgi
+++ b/editflagtypes.cgi
@@ -453,7 +453,7 @@ sub get_products_and_components {
# Let's sort the list by classifications.
@products = ();
- push(@products, @{$class{$_->id}}) foreach Bugzilla::Classification->get_all;
+ push(@products, @{$class{$_->id} || []}) foreach Bugzilla::Classification->get_all;
}
}
diff --git a/taskgraph.json b/taskgraph.json
index 7433db6..ba1d1f3 100644
--- a/taskgraph.json
+++ b/taskgraph.json
@@ -17,8 +17,8 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
"TEST_SUITE": "sanity"
},
@@ -54,8 +54,8 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
"TEST_SUITE": "docs"
},
@@ -91,8 +91,8 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
"TEST_SUITE": "webservices"
},
@@ -133,15 +133,15 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
"TEST_SUITE": "selenium"
},
"artifacts": {
"public/runtests_log": {
"type": "file",
- "path": "/runtests.log",
+ "path": "/tmp/runtests.log",
"expires": "2018-02-17T17:33:38.806Z"
},
"public/httpd_error_log": {
@@ -151,7 +151,7 @@
},
"public/selenium_log": {
"type": "file",
- "path": "/selenium.log",
+ "path": "/tmp/selenium.log",
"expires": "2018-02-17T17:33:38.806Z"
}
}
@@ -180,15 +180,16 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla:pgsql",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
+ "BUGS_DB_DRIVER": "pg",
"TEST_SUITE": "webservices"
},
"artifacts": {
"public/runtests_log": {
"type": "file",
- "path": "/runtests.log",
+ "path": "/tmp/runtests.log",
"expires": "2018-02-17T17:33:38.806Z"
},
"public/httpd_error_log": {
@@ -222,15 +223,16 @@
"provisionerId": "aws-provisioner-v1",
"workerType": "b2gtest",
"payload": {
- "image": "dklawren/docker-bugzilla:pgsql",
- "command": ["/runtests.sh"],
+ "image": "bugzilla/bugzilla-ci",
+ "command": ["runtests.sh"],
"env": {
+ "BUGS_DB_DRIVER": "pg",
"TEST_SUITE": "selenium"
},
"artifacts": {
"public/runtests_log": {
"type": "file",
- "path": "/runtests.log",
+ "path": "/tmp/runtests.log",
"expires": "2018-02-17T17:33:38.806Z"
},
"public/httpd_error_log": {
@@ -240,7 +242,7 @@
},
"public/selenium_log": {
"type": "file",
- "path": "/selenium.log",
+ "path": "/tmp/selenium.log",
"expires": "2018-02-17T17:33:38.806Z"
}
}
diff --git a/template/en/default/pages/release-notes.html.tmpl b/template/en/default/pages/release-notes.html.tmpl
index 358298b..c2be246 100644
--- a/template/en/default/pages/release-notes.html.tmpl
+++ b/template/en/default/pages/release-notes.html.tmpl
@@ -69,7 +69,7 @@
(<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1259881">[% terms.Bug %] 1259881</a>)</li>
<li>An extension which allows user-controlled data to be used as a link in
tabs could trigger XSS if the data is not correctly sanitized.
- [%+ terms. Bugzilla %] no longer relies on the extension to do the sanity
+ [%+ terms.Bugzilla %] no longer relies on the extension to do the sanity
check. A vanilla installation is not affected as no tab is user-controlled.
(<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1250114">[% terms.Bug %] 1250114</a>)</li>
<li>Extensions can now easily override the favicon used for the
@@ -205,6 +205,7 @@
you.</p>
+<a name="v50_feat"></a>
<h2 id="feat">New Features and Improvements</h2>
<ul>