aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2015-02-05 22:02:19 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2015-02-05 22:02:19 +0100
commitb4fa8c4adbbb3f3ec8e512fc8f3bbea76d4b3097 (patch)
tree975ffbffeacb2c0e3d1ebebe6b812e5175c10855
parentstart x11 init script support (diff)
downloadgentoo-vdr-scripts-b4fa8c4adbbb3f3ec8e512fc8f3bbea76d4b3097.tar.gz
gentoo-vdr-scripts-b4fa8c4adbbb3f3ec8e512fc8f3bbea76d4b3097.tar.bz2
gentoo-vdr-scripts-b4fa8c4adbbb3f3ec8e512fc8f3bbea76d4b3097.zip
filled README.x11-server, initfile, conffile
-rw-r--r--README.x11-setup26
-rw-r--r--etc/conf.d/vdr16
-rw-r--r--etc/init.d/Makefile2
-rw-r--r--[-rwxr-xr-x]etc/init.d/vdr0
-rw-r--r--etc/init.d/vdr-frontend14
-rw-r--r--etc/init.d/vdr-x118
-rw-r--r--[-rwxr-xr-x]etc/init.d/wakeup-reboot-halt0
7 files changed, 48 insertions, 18 deletions
diff --git a/README.x11-setup b/README.x11-setup
index 4653a81..b587550 100644
--- a/README.x11-setup
+++ b/README.x11-setup
@@ -1 +1,25 @@
-ToDo
+# $ID: $
+
+Instructions for usage and configuration with init script vdr-x11
+
+media-plugins/vdr-sofhddevice
+media-plugins/vdr-xineliboutput
+need a minimal X server
+
+We recommend to install a minimal X server by
+USE="minimal xorg" emerge x11-base/xorg-server -a
+Use-flag xorg is recommended!
+
+It is not part of this README how to get a working X install.
+Please refer for this to the depended xorg howto's.
+
+Is your X server setup finished, it is easy to start your x server with
+our provided init script /etc/init.d/vdr-x11.
+We add by default minimal variables to the initscript to start the x server.
+
+To fit your own setup, please refer to the man page xorg.
+
+It is simple to add your own variables by using
+/etc/conf.d/vdr --> Variable X11_SERVER=
+This will unset all default provided variables from the init script.
+There are only variables to add, without to call the x11 lib /usr/bin/X !!!
diff --git a/etc/conf.d/vdr b/etc/conf.d/vdr
index ef0b8e1..12e9fc6 100644
--- a/etc/conf.d/vdr
+++ b/etc/conf.d/vdr
@@ -125,6 +125,22 @@ LOG="3"
# default: 0
#SCRIPT_DEBUG_LEVEL="1"
+###########################################################
+# Expert X11 Settings #
+###########################################################
+
+# To fit
+# media-plugins/vdr-softhddevice
+# media-plugins/vdr-xineliboutput
+# we need a minimal configured X11 server
+# Please refer for detailed info to gentoo-vdr-scripts README.x11-setup
+#
+# init-file -> vdr-x11
+#
+# X lib startparamter
+# allowed values: see 'man xorg'
+# default: ':0 -br -nocursor -nolisten tcp -quiet'
+#PLAIN_X=" "
###########################################################
# Expert Settings #
diff --git a/etc/init.d/Makefile b/etc/init.d/Makefile
index 35373ac..307d619 100644
--- a/etc/init.d/Makefile
+++ b/etc/init.d/Makefile
@@ -4,7 +4,7 @@ SHELL = /bin/bash
MYDIR = $(DESTDIR)/etc/init.d
SUBDIRS =
-BINS = vdr vdr-x11 vdr-frontend wakeup-reboot-halt
+BINS = vdr vdr-x11 wakeup-reboot-halt
CONFS =
all:
diff --git a/etc/init.d/vdr b/etc/init.d/vdr
index 0b1644f..0b1644f 100755..100644
--- a/etc/init.d/vdr
+++ b/etc/init.d/vdr
diff --git a/etc/init.d/vdr-frontend b/etc/init.d/vdr-frontend
deleted file mode 100644
index 60cb99c..0000000
--- a/etc/init.d/vdr-frontend
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-command="/usr/bin/vdr-sxfe"
-command_args="--silent --fullscreen --syslog --reconnect xvdr://localhost &>/dev/null"
-pidfile="/var/run/vdr-frontend.pid"
-start_stop_daemon_args="--user vdr --group vdr --make-pidfile --background"
-
-depend() {
- need vdr-x11
- after vdr-x11
-}
diff --git a/etc/init.d/vdr-x11 b/etc/init.d/vdr-x11
index a4605fa..1b3ee97 100644
--- a/etc/init.d/vdr-x11
+++ b/etc/init.d/vdr-x11
@@ -3,9 +3,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+description:"Start minimal X server for VDR"
+
+source /etc/conf.d/vdr
+
command="/usr/bin/X"
-command_args="-nolisten tcp :0 -quiet -br -nocursor"
-start_stop_daemon_args="--user vdr --group vdr --make-pidfile --background"
+command_args="${X11_SERVER:=\:0 -br -nocursor -nolisten tcp -quiet"
+start_stop_daemon_args="--make-pidfile --background"
pidfile="/var/run/vdr-x11.pid"
depend() {
diff --git a/etc/init.d/wakeup-reboot-halt b/etc/init.d/wakeup-reboot-halt
index ae4a2e1..ae4a2e1 100755..100644
--- a/etc/init.d/wakeup-reboot-halt
+++ b/etc/init.d/wakeup-reboot-halt