aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoridl0r <idl0r@gentoo.org>2009-05-12 18:14:43 +0000
committeridl0r <idl0r@gentoo.org>2009-05-12 18:14:43 +0000
commit13ce0a519afa955ce22d18269038f680ae331999 (patch)
tree3795e8d869d6dd65feb006a98af4858fd58f106c
parentIgnore .git dir when running echangelog in the repository root, fixes bug 199... (diff)
downloadgentoolkit-13ce0a519afa955ce22d18269038f680ae331999.tar.gz
gentoolkit-13ce0a519afa955ce22d18269038f680ae331999.tar.bz2
gentoolkit-13ce0a519afa955ce22d18269038f680ae331999.zip
Fix regex, bug 269557, thanks to Samuli Suominen <ssuominen@gentoo.org>.
svn path=/trunk/gentoolkit-dev/; revision=638
-rwxr-xr-xsrc/echangelog/echangelog18
1 files changed, 9 insertions, 9 deletions
diff --git a/src/echangelog/echangelog b/src/echangelog/echangelog
index e288650..cd31eb2 100755
--- a/src/echangelog/echangelog
+++ b/src/echangelog/echangelog
@@ -166,6 +166,15 @@ sub update_cat_pn {
return $t;
}
+# Just to ensure we don't get duplicate entries.
+sub mypush(\@@) {
+ my $aref = shift;
+
+ foreach my $value (@_) {
+ push(@{$aref}, $value) if !grep(/^\Q$value\E$/, @{$aref});
+ }
+}
+
GetOptions(
'help' => \$opt_help,
'strict' => \$opt_strict,
@@ -426,15 +435,6 @@ sub sortfunc($$) {
return 0;
}
-# Just to ensure we don't get duplicate entries.
-sub mypush(\@@) {
- my $aref = shift;
-
- foreach my $value (@_) {
- push(@{$aref}, $value) if !grep(/^$value$/, @{$aref});
- }
-}
-
# Forget ebuilds that only have changed copyrights, unless that's all
# the changed files we have
@ebuilds = grep /\.ebuild$/, @files;