aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-04-09 17:48:32 +0200
committerChristian Ruppert <idl0r@gentoo.org>2012-04-09 17:48:32 +0200
commitdb6c7f618afd8e080ddc27fa133a711b8f049af3 (patch)
treed582971267a053c9743b418fbf25011197563cd4
parentMinor cleanup (diff)
downloadgentoolkit-db6c7f618afd8e080ddc27fa133a711b8f049af3.tar.gz
gentoolkit-db6c7f618afd8e080ddc27fa133a711b8f049af3.tar.bz2
gentoolkit-db6c7f618afd8e080ddc27fa133a711b8f049af3.zip
Add prototypes back for now
-rwxr-xr-xsrc/echangelog/echangelog6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/echangelog/echangelog b/src/echangelog/echangelog
index a6a9533..bf25af7 100755
--- a/src/echangelog/echangelog
+++ b/src/echangelog/echangelog
@@ -106,7 +106,7 @@ sub version {
exit 0;
}
-sub getenv {
+sub getenv($) {
my $key = shift;
# Ensure our variable exist
@@ -201,7 +201,7 @@ sub check_vcs_dir {
}
# Just to ensure we don't get duplicate entries.
-sub mypush {
+sub mypush(\@@) {
my $aref = shift;
foreach my $value (@_) {
@@ -430,7 +430,7 @@ EOT
# Sort the list of files as portage does. None of the operations through
# the rest of the script should break this sort.
-sub sortfunc {
+sub sortfunc($$) {
my ($a, $b) = @_;
(my $va = $a) =~ s/.*?-(\d.*?)(?:\.ebuild)?$/$1/;
(my $vb = $b) =~ s/.*?-(\d.*?)(?:\.ebuild)?$/$1/;