aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfuzzyray <fuzzyray@gentoo.org>2009-12-09 20:07:50 +0000
committerfuzzyray <fuzzyray@gentoo.org>2009-12-09 20:07:50 +0000
commiteef92c84d6f9915f864de969d0d25018c428daf4 (patch)
tree634eb2b4add46b3497fae3366168009d783fa7c8 /README.dev
parentModify setup.py to run set_version correctly on revdep-rebuild (diff)
downloadgentoolkit-eef92c84d6f9915f864de969d0d25018c428daf4.tar.gz
gentoolkit-eef92c84d6f9915f864de969d0d25018c428daf4.tar.bz2
gentoolkit-eef92c84d6f9915f864de969d0d25018c428daf4.zip
Updated README.dev, with gentoo specific instructions
svn path=/trunk/gentoolkit/; revision=709
Diffstat (limited to 'README.dev')
-rw-r--r--README.dev19
1 files changed, 17 insertions, 2 deletions
diff --git a/README.dev b/README.dev
index 7a33d1c..feefe47 100644
--- a/README.dev
+++ b/README.dev
@@ -12,14 +12,29 @@ pylint --rcfile=pylintrc yourfile.py
Creating a release:
===================
+Note: We are using VERSION="0.3.0" simply as an example.
+
- Run Gentoolkit's test suite, make sure it passes:
+Note: requires dev-python/snakeoil
./setup.py test
+
- Create a tag for the release
+svn copy svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/trunk \
+ svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/tags/gentoolkit-0.3.0 \
+ -m "Tagging the <VERSION> release of gentoolkit."
+svn update to pull the tag from subversion
+cd to the local tags/gentoolkit-0.3.0 directory
+
- Set the version of the release:
-VERSION="0.3.0" ./setup set_version
+VERSION="0.3.0" ./setup.py set_version
+
- Create a source distribution (you need to add VERSION here, too):
VERSION="0.3.0" ./setup.py sdist
+Transfer dist/gentoolkit-0.3.0.tar.gz to dev.gentoo.org:/space/distfiles-local
+
- Reset svn version to 'svn' (default):
./setup.py set_version
+
- Clean up temporary files:
-./setup clean -a
+./setup.py clean -a
+