summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2014-10-24 12:59:59 -0500
committerPaul Varner <fuzzyray@gentoo.org>2014-10-24 12:59:59 -0500
commit91023ef967c680db9307b5c58762e8872346167e (patch)
tree00cb44a435a5fe1f8f7725ac37844dc2814136f4 /bin
parentsetup.py: Fix installation on slackware systems (diff)
downloadgentoolkit-91023ef967c680db9307b5c58762e8872346167e.tar.gz
gentoolkit-91023ef967c680db9307b5c58762e8872346167e.tar.bz2
gentoolkit-91023ef967c680db9307b5c58762e8872346167e.zip
Fix gawk warning escape sequence \. treated as plain. Bug 526400
Diffstat (limited to 'bin')
-rwxr-xr-xbin/revdep-rebuild.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/revdep-rebuild.sh b/bin/revdep-rebuild.sh
index 3179a83..01a0454 100755
--- a/bin/revdep-rebuild.sh
+++ b/bin/revdep-rebuild.sh
@@ -842,7 +842,7 @@ main_checks() {
done < <(
# Regexify LD_LIBRARY_MASK. Exclude it from the search.
LD_LIBRARY_MASK="${LD_LIBRARY_MASK//$'\n'/|}"
- gawk -v ldmask="(${LD_LIBRARY_MASK//./\\\.})" '
+ gawk -v ldmask="(${LD_LIBRARY_MASK//./\\\\.})" '
/no version information available/ && $0 !~ ldmask {
gsub(/[()]/, "", $NF)
if (seen[$NF]++) next