aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2012-12-18 04:40:56 -0600
committerPaul Varner <fuzzyray@gentoo.org>2012-12-18 04:40:56 -0600
commit8745911eb903f1da301d99d5949f655b0190ca6f (patch)
tree7aa7d40802a6ae6ed2b1e2ccd6b749bb0e81c9e7 /setup.py
parenteclean/test_clean: remove unused test_test_support import (diff)
downloadgentoolkit-8745911eb903f1da301d99d5949f655b0190ca6f.tar.gz
gentoolkit-8745911eb903f1da301d99d5949f655b0190ca6f.tar.bz2
gentoolkit-8745911eb903f1da301d99d5949f655b0190ca6f.zip
Fix setup.py so that either VERSION or PVR will set the version.
This fixes the issue with egg-info always having a version number of 9999. Fix is from Brian Dolbec courtesy of mirrorselect.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1efba94..e50d76f 100755
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ import io
sys.path.insert(0, os.path.join(os.path.dirname(__file__), 'pym'))
-__version__ = os.getenv('VERSION', default='9999')
+__version__ = os.getenv('VERSION', default=os.getenv('PVR', default='9999'))
cwd = os.getcwd()