aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog6
-rw-r--r--bin/eclean2
2 files changed, 7 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 1116f96..5c1c0c5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,4 +1,8 @@
-2009-05-09: Paul Varner <fuzzyray@gentoo.org>
+2009-05-06: Paul Varner <fuzzyray@gentoo.org>
+ * eclean: Add patch from MATSUI Tetsushi to have eclean take EPREFIX
+ into account for distfiles.exclude. (Bug 241600)
+
+2009-05-05: Paul Varner <fuzzyray@gentoo.org>
* equery: Added modular rewrite from djanderson
* gentoolkit: Added modular rewrite from djanderson
* All: converted to setup.py build system
diff --git a/bin/eclean b/bin/eclean
index 5497cf3..a004388 100644
--- a/bin/eclean
+++ b/bin/eclean
@@ -802,6 +802,8 @@ def main():
# parse the exclusion file
if not 'exclude-file' in myoptions:
my_exclude_file = "/etc/%s/%s.exclude" % (__productname__ , myaction)
+ if 'EPREFIX' in os.environ:
+ my_exclude_file = os.environ['EPREFIX'] + my_exclude_file
if os.path.isfile(my_exclude_file):
myoptions['exclude-file'] = my_exclude_file
if 'exclude-file' in myoptions: