aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/echangelog/Makefile')
-rw-r--r--src/echangelog/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/echangelog/Makefile b/src/echangelog/Makefile
new file mode 100644
index 0000000..61c5e57
--- /dev/null
+++ b/src/echangelog/Makefile
@@ -0,0 +1,23 @@
+# Copyright 2004 Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright 2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+# $Header$
+
+include ../../makedefs.mak
+
+%.1 : %.pod
+ pod2man $< > $@
+
+.PHONY: all
+all: echangelog.1
+
+dist: echangelog.1
+ mkdir -p ../../$(distdir)/src/echangelog/
+ cp Makefile AUTHORS README TODO ChangeLog echangelog echangelog.pod echangelog.1 ../../$(distdir)/src/echangelog/
+
+install: all
+ install -m 0755 echangelog $(bindir)/
+ install -d $(docdir)/echangelog
+ install -m 0644 AUTHORS README $(docdir)/echangelog/
+ install -m 0644 echangelog.1 $(mandir)/