aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-18 23:05:54 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-18 23:05:54 +0200
commit7a029594c850603a417d3575fd43132377f541f3 (patch)
tree5353e4d7ac4ff072e00d11072812ea91335b9d0e
parentx11-libs/tepl: fix slot for 4.2 (diff)
downloadgnome-7a029594c850603a417d3575fd43132377f541f3.tar.gz
gnome-7a029594c850603a417d3575fd43132377f541f3.tar.bz2
gnome-7a029594c850603a417d3575fd43132377f541f3.zip
x11-libs/gtk+: Remove very outdated live ebuild
It's gtk4 into SLOT=3, tries to build with autotools (isn't a thing for gtk4 git), and hasn't been synced with other changes for over 3 years, it seems. On top of that, later blind fixes broke the dependency string. Closes: https://bugs.gentoo.org/674514 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/gtk+/files/gtk+-3.16.2-remove_update-icon-cache.patch24
-rw-r--r--x11-libs/gtk+/files/gtk+-non-bash-support.patch56
-rw-r--r--x11-libs/gtk+/files/settings.ini4
-rw-r--r--x11-libs/gtk+/gtk+-9999.ebuild265
-rw-r--r--x11-libs/gtk+/metadata.xml23
5 files changed, 0 insertions, 372 deletions
diff --git a/x11-libs/gtk+/files/gtk+-3.16.2-remove_update-icon-cache.patch b/x11-libs/gtk+/files/gtk+-3.16.2-remove_update-icon-cache.patch
deleted file mode 100644
index b121dd57..00000000
--- a/x11-libs/gtk+/files/gtk+-3.16.2-remove_update-icon-cache.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From d83443d10381a53637226b937094454951de44c1 Mon Sep 17 00:00:00 2001
-From: Ole Reifschneider <tranquility@gentoo.org>
-Date: Thu, 16 Apr 2015 23:51:51 +0200
-Subject: [PATCH] Remove update-icon-cache from bin_PROGRAMS
-
----
- gtk/Makefile.am | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/gtk/Makefile.am b/gtk/Makefile.am
-index 83dfe31..a5afc03 100644
---- a/gtk/Makefile.am
-+++ b/gtk/Makefile.am
-@@ -1380,7 +1380,6 @@ endif
- #
- bin_PROGRAMS = \
- gtk-query-immodules-3.0 \
-- gtk-update-icon-cache \
- gtk-encode-symbolic-svg \
- gtk-launch
-
---
-2.0.5
-
diff --git a/x11-libs/gtk+/files/gtk+-non-bash-support.patch b/x11-libs/gtk+/files/gtk+-non-bash-support.patch
deleted file mode 100644
index a1aac42c..00000000
--- a/x11-libs/gtk+/files/gtk+-non-bash-support.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 43a4a28cdc60ac7347bb89f84cf049cb3401621d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
-Date: Sun, 26 Oct 2014 01:59:33 +0400
-Subject: [PATCH] gtk/Makefile.am: Remove bashisms
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-- improve portability of ECHO
-- remove use of shopt
-
-https://bugzilla.gnome.org/show_bug.cgi?id=738835
-
-From: Alexander Tsoy <alexander@tsoy.me>
-Signed-off-by: RĂ©mi Cardona <remi@gentoo.org>
----
- gtk/Makefile.am | 13 +++++--------
- 1 file changed, 5 insertions(+), 8 deletions(-)
-
-diff --git a/gtk/Makefile.am b/gtk/Makefile.am
-index 96c651a..b1478ce 100644
---- a/gtk/Makefile.am
-+++ b/gtk/Makefile.am
-@@ -19,11 +19,7 @@ GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %
- endif
-
- SUBDIRS = inspector native .
--if OS_DARWIN
-- ECHO="echo"
--else
-- ECHO=echo -e
--endif
-+ECHO=printf '%b\n'
-
- if HAVE_CLOUDPRINT
- if HAVE_PAPI_CUPS
-@@ -1405,12 +1401,13 @@ gtk.gresource.xml: Makefile.am
- n=`basename $$f`; \
- $(ECHO) " <file compressed=\"true\">ui/$$n</file>" >> $@; \
- done; \
-- shopt -s nullglob; \
- for s in 16x16 22x22 24x24 32x32 48x48; do \
- for c in actions status; do \
- for f in $(srcdir)/resources/icons/$$s/$$c/*.png; do \
-- n=`basename $$f`; \
-- $(ECHO) " <file>icons/$$s/$$c/$$n</file>" >> $@; \
-+ if [ -e "$$f" ] ; then \
-+ n=`basename $$f`; \
-+ $(ECHO) " <file>icons/$$s/$$c/$$n</file>" >> $@; \
-+ fi; \
- done; \
- done; \
- done; \
---
-2.3.0
-
diff --git a/x11-libs/gtk+/files/settings.ini b/x11-libs/gtk+/files/settings.ini
deleted file mode 100644
index a65c0a81..00000000
--- a/x11-libs/gtk+/files/settings.ini
+++ /dev/null
@@ -1,4 +0,0 @@
-[Settings]
-gtk-theme-name = Adwaita
-gtk-icon-theme-name = gnome
-gtk-cursor-theme-name = Adwaita
diff --git a/x11-libs/gtk+/gtk+-9999.ebuild b/x11-libs/gtk+/gtk+-9999.ebuild
deleted file mode 100644
index b6b62d7d..00000000
--- a/x11-libs/gtk+/gtk+-9999.ebuild
+++ /dev/null
@@ -1,265 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="3"
-IUSE="aqua broadway cloudprint colord cups examples +introspection test vim-syntax wayland X xinerama"
-REQUIRED_USE="
- || ( aqua wayland X )
- xinerama? ( X )
-"
-
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-# FIXME: introspection data is built against system installation of gtk+:3
-# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
-COMMON_DEPEND="
- >=dev-libs/atk-2.15[introspection?,${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.45.8:2[${MULTILIB_USEDEP}]
- media-libs/fontconfig[${MULTILIB_USEDEP}]
- >=media-libs/libepoxy-1.0[${MULTILIB_USEDEP}]
- >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
- >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
- >=x11-libs/pango-1.37.3[introspection?,${MULTILIB_USEDEP}]
- x11-misc/shared-mime-info
-
- cloudprint? (
- >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
- >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
- colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
- cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
- introspection? ( >=dev-libs/gobject-introspection-1.39:= )
- wayland? (
- >=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
- >=dev-libs/wayland-protocols-1.0.0[${MULTILIB_USEDEP}]
- media-libs/mesa[wayland,${MULTILIB_USEDEP}]
- >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
- )
- X? (
- >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
- x11-libs/libXrender[${MULTILIB_USEDEP}]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
- x11-libs/libXext[${MULTILIB_USEDEP}]
- >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
- x11-libs/libXcursor[${MULTILIB_USEDEP}]
- x11-libs/libXfixes[${MULTILIB_USEDEP}]
- x11-libs/libXcomposite[${MULTILIB_USEDEP}]
- x11-libs/libXdamage[${MULTILIB_USEDEP}]
- xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
- )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xsl-stylesheets
- app-text/docbook-xml-dtd:4.1.2
- dev-libs/libxslt
- dev-libs/gobject-introspection-common
- >=dev-util/gdbus-codegen-2.38.2
- >=dev-util/gtk-doc-am-1.20
- >=sys-devel/gettext-0.18.3[${MULTILIB_USEDEP}]
- virtual/pkgconfig[${MULTILIB_USEDEP}]
- X? ( x11-base/xorg-proto )
- )
- test? (
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.20 )"
-fi
-
-# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
-# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
-# >=xorg-server-1.11.4 needed for
-# https://mail.gnome.org/archives/desktop-devel-list/2012-March/msg00024.html
-RDEPEND="${COMMON_DEPEND}
- >=dev-util/gtk-update-icon-cache-3
- !<gnome-base/gail-1000
- !<x11-libs/vte-0.31.0:2.90
- >=x11-themes/adwaita-icon-theme-3.14
- X? ( !<x11-base/xorg-server-1.11.4 )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )
-"
-# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
-PDEPEND="
- gnome-base/librsvg[${MULTILIB_USEDEP}]
- vim-syntax? ( app-vim/gtk-syntax )
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/gtk-query-immodules-3.0
-)
-
-strip_builddir() {
- local rule=$1
- shift
- local directory=$1
- shift
- sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
- || die "Could not strip director ${directory} from build."
-}
-
-src_prepare() {
- # -O3 and company cause random crashes in applications. Bug #133469
- replace-flags -O3 -O2
- strip-flags
-
- if ! use test ; then
- # don't waste time building tests
- strip_builddir SRC_SUBDIRS testsuite Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS testsuite Makefile.in
- strip_builddir SRC_SUBDIRS tests Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS tests Makefile.in
- fi
-
- if ! use examples; then
- # don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS demos Makefile.in
- strip_builddir SRC_SUBDIRS examples Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS examples Makefile.in
- fi
-
- # Do no build and install gtk-update-icon-cache which is done by gtk+:2
- epatch "${FILESDIR}"/${PN}-3.16.2-remove_update-icon-cache.patch
-
- epatch_user
-
- eautoreconf
- [[ ${PV} = 9999 ]] && gnome2_src_prepare
-}
-
-multilib_src_configure() {
- local myconf=""
-
- [[ ${PV} = 9999 ]] && myconf="${myconf} $(use_enable doc gtk-doc)"
-
- # Passing --disable-debug is not recommended for production use
- # need libdir here to avoid a double slash in a path that libtool doesn't
- # grok so well during install (// between $EPREFIX and usr ...)
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- $(use_enable aqua quartz-backend) \
- $(use_enable broadway broadway-backend) \
- $(use_enable cloudprint) \
- $(use_enable colord) \
- $(use_enable cups cups auto) \
- $(multilib_native_use_enable introspection) \
- $(use_enable wayland wayland-backend) \
- $(use_enable X x11-backend) \
- $(use_enable X xcomposite) \
- $(use_enable X xdamage) \
- $(use_enable X xfixes) \
- $(use_enable X xkb) \
- $(use_enable X xrandr) \
- $(use_enable xinerama) \
- --disable-papi \
- --disable-mir-backend \
- --enable-man \
- --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config" \
- ${myconf}
-
- # work-around gtk-doc out-of-source brokedness
- if multilib_is_native_abi; then
- local d
- for d in gdk gtk libgail-util; do
- ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
- done
- fi
-}
-
-multilib_src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- unset DISPLAY #527682
- GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
-}
-
-multilib_src_install() {
- gnome2_src_install
-
- # add -framework Carbon to the .pc files, bug #???
- if use aqua ; then
- for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
- sed -e "s:Libs\: :Libs\: -framework Carbon :" \
- -i "${ED%/}"/usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
- done
- fi
-}
-
-multilib_src_install_all() {
- insinto /etc/gtk-3.0
- doins "${FILESDIR}"/settings.ini
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
-
- multilib_pkg_preinst() {
- # Make immodules.cache belongs to gtk+ alone
- local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
-
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
- }
- multilib_parallel_foreach_abi multilib_pkg_preinst
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- multilib_pkg_postinst() {
- gnome2_query_immodules_gtk3 \
- || die "Update immodules cache failed (for ${ABI})"
- }
- multilib_parallel_foreach_abi multilib_pkg_postinst
-
- if ! has_version "app-text/evince"; then
- elog "Please install app-text/evince for print preview functionality."
- elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
- elog "add it to your settings.ini file."
- fi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
-
- if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
- multilib_pkg_postrm() {
- rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
- }
- multilib_foreach_abi multilib_pkg_postrm
- fi
-}
diff --git a/x11-libs/gtk+/metadata.xml b/x11-libs/gtk+/metadata.xml
deleted file mode 100644
index efa1edaa..00000000
--- a/x11-libs/gtk+/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription>
- GTK+ is a multi-platform toolkit for creating graphical user
- interfaces. Offering a complete set of widgets, GTK+ is suitable
- for projects ranging from small one-off projects to complete
- application suites.
- </longdescription>
- <use>
- <flag name="broadway">Enable the GDK Broadway backend.</flag>
- <flag name="cloudprint">Enable printing via Google Cloud Print.</flag>
- <flag name="colord">Use <pkg>x11-misc/colord</pkg> for color management
- in printing</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:gtk:gtk%2B</remote-id>
- </upstream>
-</pkgmetadata>