summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-05-02 08:24:41 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-05-02 08:25:18 -0400
commitd6c0a730d416f1f7ae2393c7eac9b6e5eb715eb5 (patch)
treedd53595b7b4ffa44c9cfc23ec9bb341680599f37
parentgui-libs/amtk: remove, available in ::gentoo (diff)
downloadgnome-d6c0a730d416f1f7ae2393c7eac9b6e5eb715eb5.tar.gz
gnome-d6c0a730d416f1f7ae2393c7eac9b6e5eb715eb5.tar.bz2
gnome-d6c0a730d416f1f7ae2393c7eac9b6e5eb715eb5.zip
gnome-extra/evolution-data-server: 3.30.5-r1 → 3.32.2
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.32.1.ebuild152
-rw-r--r--gnome-extra/evolution-data-server/metadata.xml10
3 files changed, 160 insertions, 3 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
new file mode 100644
index 00000000..9d452fc1
--- /dev/null
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -0,0 +1 @@
+DIST evolution-data-server-3.32.1.tar.xz 4580500 BLAKE2B b644c3b86359e22f631c9db3999cdc82247f4b74c2772c73ab1fe496d3d28306525a64f9bab336b407de6485c455100f1d09918de5479df2f8e7e9a7a2cc4bd5 SHA512 bbaf9f1eca40b02978df155a64bbc8da94d56e2e4f4602905784f7974a1622ce0798d1d6ee75a560a4082fb1f8d1b621a2c1dccb0056715345273a265abea96d
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.32.1.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.32.1.ebuild
new file mode 100644
index 00000000..3526183c
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.32.1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+VALA_USE_DEPEND="vapigen"
+
+inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/62" # subslot = libcamel-1.2 soname version
+
+IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ipv6 ldap kerberos oauth vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+# gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
+# berkdb needed only for migrating old addressbook data from <3.13 versions, bug #519512
+# >=libical-3.0.2 present at build-time ensures less memory usage by calendar backend
+gdata_depend=">=dev-libs/libgdata-0.17.7:="
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.2:=
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.42:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.10:3
+ >=media-libs/libcanberra-0.25[gtk3]
+ )
+ oauth? (
+ >=dev-libs/json-glib-1.0.4
+ >=net-libs/webkit-gtk-2.11.91:4
+ ${gdata_depend}
+ )
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.8:=
+ ${gdata_depend} )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ gtk-doc? ( >=dev-util/gtk-doc-1.14 )
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# Some tests fail due to missing locales.
+# Also, dbus tests are flaky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test !test? ( test )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
+src_prepare() {
+ use vala && vala_src_prepare
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+
+ # Make CMakeLists versioned vala enabled
+ sed -e "s;\(find_program(VALAC\) valac);\1 ${VALAC});" \
+ -e "s;\(find_program(VAPIGEN\) vapigen);\1 ${VAPIGEN});" \
+ -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ local google_enable
+ if use oauth || use gnome-online-accounts; then
+ google_enable="ON"
+ else
+ google_enable="OFF"
+ fi
+
+ # phonenumber does not exist in tree
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_PRIVATE_DOCS=$(usex gtk-doc)
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DWITH_KRB5=$(usex kerberos)
+ -DWITH_KRB5_INCLUDES=$(usex kerberos "${EPREFIX}"/usr "")
+ -DWITH_KRB5_LIBS=$(usex kerberos "${EPREFIX}"/usr/$(get_libdir) "")
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DWITH_PHONENUMBER=OFF
+ -DENABLE_SMIME=ON
+ -DENABLE_GTK=$(usex gtk)
+ -DENABLE_CANBERRA=$(usex gtk)
+ -DENABLE_OAUTH2=$(usex oauth)
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_GOA=$(usex gnome-online-accounts)
+ -DENABLE_UOA=OFF
+ -DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
+ # ENABLE_BACKTRACES requires libdwarf ?
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_GOOGLE=${google_enable}
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_VALA_BINDINGS=$(usex vala)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym ../../../usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
diff --git a/gnome-extra/evolution-data-server/metadata.xml b/gnome-extra/evolution-data-server/metadata.xml
index 3177c37e..b33a2633 100644
--- a/gnome-extra/evolution-data-server/metadata.xml
+++ b/gnome-extra/evolution-data-server/metadata.xml
@@ -6,9 +6,13 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
- <flag name="gnome-online-accounts">Enable using
- <pkg>net-libs/gnome-online-accounts</pkg> for authorization</flag>
- <flag name="google">Enable support for google authentication, contacts and tasks</flag>
+ <flag name="berkdb"><pkg>sys-libs/db</pkg> support needed to migrate old (pre-3.13 evolution versions) addressbook data</flag>
+ <flag name="gnome-online-accounts">Enable <pkg>net-libs/gnome-online-accounts</pkg> based Google authentication support</flag>
+ <flag name="google">Enable internal Google authentication support. If gnome-online-accounts is enabled and used, this is not necessary,
+ but both can be supported at the same time with different setup at runtime</flag>
+ <flag name="oauth">Enable internal OAuth2 authentication support for Google and Outlook.com.
+ If gnome-online-accounts is enabled and used, this is not necessary,
+ but both can be supported at the same time with different setup at runtime</flag>
<flag name="weather">Enable optional weather calendar support</flag>
</use>
</pkgmetadata>