summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gnome-todo/Manifest8
-rw-r--r--gnome-extra/gnome-todo/files/gnome-todo-3.20.2-link-failure.patch27
-rw-r--r--gnome-extra/gnome-todo/gnome-todo-3.20.2.ebuild42
3 files changed, 73 insertions, 4 deletions
diff --git a/gnome-extra/gnome-todo/Manifest b/gnome-extra/gnome-todo/Manifest
index 677cb2f6..34c4e263 100644
--- a/gnome-extra/gnome-todo/Manifest
+++ b/gnome-extra/gnome-todo/Manifest
@@ -2,10 +2,10 @@
Hash: SHA512
DIST gnome-todo-3.18.1.tar.xz 610892 SHA256 7da17c39f46accb897b8af159f6accabc4e2afa4503d8d36138b5937cf5bcc51 SHA512 11ab0479e1ebcada5a871afd867eedb5fa31b0f4cf1d97a64021daa15593d732673db9e5df3003e11fb26a222d20e8ce9b59664d57472151102580857f87f443 WHIRLPOOL 8642e0187fee6abf1f91b505c00a8def5317eb3ee1e0f4911f9147a8a7e41bbfd804f7bd5c7e787a9d7f827da1ebc1feec19f3fbc15635ca802b21331ec80e3a
+DIST gnome-todo-3.20.2.tar.xz 649904 SHA256 6e0452733789b0a4d2f44f9870bdba6aa4c4190615627bacf6e40e8ec9a47519 SHA512 cd7ae79ad6c69e69c0d7f58260d60dd791cb1e71f0b34fbd165fa6660bf59679b4bbce777948c192fbb83006aed213d0b441ab71cf1bd9ce9b00e194e3e76679 WHIRLPOOL 0862df2fc7b58dc151d8f9f6b56a9a9a7b941bfbc1173463e7bf71d76e72be50c8a62664c3ddfb54cf23a3293061e01340464ae424ad479322bddf2f39b7d33f
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v2
-iEYEAREKAAYFAlZttoEACgkQ1fmVwcYIWAYuFwCdGKCNGAQaEyP8PTOLALyUI5sI
-yGcAoOcilzzbEVknmyTGt0VzaJ+OfBG7
-=X9Oi
+iEYEAREKAAYFAlfPUkwACgkQ1fmVwcYIWAaNLQCgilxeYJmbvkFBfkTj8kORwpqE
+aXMAn3h5aph6D6E3Ise1L0NtpzSmVuZ+
+=jAQS
-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-todo/files/gnome-todo-3.20.2-link-failure.patch b/gnome-extra/gnome-todo/files/gnome-todo-3.20.2-link-failure.patch
new file mode 100644
index 00000000..c65b8bca
--- /dev/null
+++ b/gnome-extra/gnome-todo/files/gnome-todo-3.20.2-link-failure.patch
@@ -0,0 +1,27 @@
+From 5862bb70240b1f311e0ace880e3fcf0af1c8c5f8 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 7 Sep 2016 01:31:15 +0200
+Subject: [PATCH] Fix link failure with missing e_source_get_displayname symbol
+
+---
+ src/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 428226d..1032d29 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -98,8 +98,8 @@ gnome_todo_LDFLAGS = \
+ $(GNOME_TODO_WARN_LDFLAGS)
+
+ gnome_todo_LDADD = \
+- $(GNOME_TODO_LIBS) \
+- $(top_builddir)/plugins/eds/libeds.a
++ $(top_builddir)/plugins/eds/libeds.a \
++ $(GNOME_TODO_LIBS)
+
+ gnome_todo_DEPENDENCIES = \
+ $(top_builddir)/plugins/eds/libeds.a
+--
+2.9.3
+
diff --git a/gnome-extra/gnome-todo/gnome-todo-3.20.2.ebuild b/gnome-extra/gnome-todo/gnome-todo-3.20.2.ebuild
new file mode 100644
index 00000000..a8938ec4
--- /dev/null
+++ b/gnome-extra/gnome-todo/gnome-todo-3.20.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome2
+
+DESCRIPTION="Personnal task manager"
+HOMEPAGE="https://wiki.gnome.org/Apps/Todo"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.43.4:2
+ >=dev-libs/gobject-introspection-1.42:=
+ >=dev-libs/libical-0.43
+ >=dev-libs/libpeas-1.17
+ >=gnome-extra/evolution-data-server-3.17.1[gtk]
+ >=net-libs/gnome-online-accounts-3.2
+ >=x11-libs/gtk+-3.19.5:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.6
+ dev-libs/appstream-glib
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-link-failure.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --enable-eds-plugin
+}