summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/files/2.56.0-Fix-building-tls-plugin-without-pkcs11.patch57
-rw-r--r--net-libs/glib-networking/glib-networking-2.56.0-r1.ebuild88
-rw-r--r--net-libs/glib-networking/metadata.xml12
4 files changed, 0 insertions, 158 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
deleted file mode 100644
index 5bb0abb5..00000000
--- a/net-libs/glib-networking/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST glib-networking-2.56.0.tar.xz 163852 BLAKE2B 42fe3469d9e7bac8e0de0fe6a9f154dbb39ed5cc43e46b1f10cb53f04fcb24f391b436dcb2c6585033e86f83079ab3530787d1454cf8f57b81a12285c867fcdf SHA512 7c34817fa08e29c1d75e253a223d7beda0f38feb731d0a4219b10a220b664974f8f51ea693b93c7ebaa77ebd5e629fcaa5a52da5092513613f6b5faf5e9a21db
diff --git a/net-libs/glib-networking/files/2.56.0-Fix-building-tls-plugin-without-pkcs11.patch b/net-libs/glib-networking/files/2.56.0-Fix-building-tls-plugin-without-pkcs11.patch
deleted file mode 100644
index b460b248..00000000
--- a/net-libs/glib-networking/files/2.56.0-Fix-building-tls-plugin-without-pkcs11.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 4e9bfe7e32767be5a18fc38734da09607f13799a Mon Sep 17 00:00:00 2001
-From: Tom Schoonjans <Tom.Schoonjans@diamond.ac.uk>
-Date: Tue, 13 Mar 2018 16:57:03 +0000
-Subject: [PATCH] Fix building tls plugin without pkcs11
-
-https://bugzilla.gnome.org/show_bug.cgi?id=794292
----
- meson.build | 3 +--
- tls/tests/meson.build | 7 ++++---
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index f923e53..0eb39e3 100644
---- a/meson.build
-+++ b/meson.build
-@@ -92,6 +92,7 @@ pkg = import('pkgconfig')
- po_dir = join_paths(meson.source_root(), 'po')
-
- top_inc = include_directories('.')
-+tls_inc = include_directories('tls')
-
- subdir('po')
-
-@@ -113,8 +114,6 @@ if enable_libproxy_support or enable_gnome_proxy_support
- endif
-
- if enable_pkcs11_support
-- tls_inc = include_directories('tls')
--
- subdir('tls/pkcs11')
- endif
-
-diff --git a/tls/tests/meson.build b/tls/tests/meson.build
-index 7e1ae13..d3611c1 100644
---- a/tls/tests/meson.build
-+++ b/tls/tests/meson.build
-@@ -1,4 +1,7 @@
--incs = [top_inc]
-+incs = [
-+ top_inc,
-+ tls_inc
-+]
-
- deps = [
- gio_dep,
-@@ -25,8 +28,6 @@ test_programs = [
- ]
-
- if enable_pkcs11_support
-- incs += tls_inc
--
- pkcs11_deps = deps + [
- libgiopkcs11_dep,
- pkcs11_dep
---
-2.17.0
-
diff --git a/net-libs/glib-networking/glib-networking-2.56.0-r1.ebuild b/net-libs/glib-networking/glib-networking-2.56.0-r1.ebuild
deleted file mode 100644
index e38ed708..00000000
--- a/net-libs/glib-networking/glib-networking-2.56.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit gnome-meson multilib-minimal virtualx
-
-DESCRIPTION="Network-related giomodules for glib"
-HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-IUSE="+gnome +libproxy smartcard test"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-libs/glib-2.56.0:2[${MULTILIB_USEDEP}]
- app-misc/ca-certificates
- >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}]
- gnome? ( gnome-base/gsettings-desktop-schemas )
- libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
- smartcard? (
- >=app-crypt/p11-kit-0.18.4[${MULTILIB_USEDEP}]
- >=net-libs/gnutls-3:=[pkcs11,${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- >=sys-devel/gettext-0.19.4
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- test? ( sys-apps/dbus[X] )
-"
-
-PATCHES=(
- "${FILESDIR}"/2.56.0-Fix-building-tls-plugin-without-pkcs11.patch
-)
-
-src_prepare() {
- default
- # Disable SSLv3 requiring fallback test, which fails with net-libs/gnutls[-sslv3], bug 595952
- # https://bugzilla.gnome.org/show_bug.cgi?id=782853
- sed -i -e '/\/tls\/connection\/fallback\/SSL/d' "${S}"/tls/tests/connection.c || die
-}
-
-multilib_src_configure() {
- gnome-meson_src_configure \
- -Dstatic_modules=false \
- -Dca_certificates_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
- $(meson_use gnome gnome_proxy_support) \
- $(meson_use libproxy libproxy_support) \
- $(meson_use smartcard pkcs11_support)
- # TODO gnutls is mandatory with meson
-}
-
-multilib_src_compile() {
- gnome-meson_src_compile
-}
-
-multilib_src_test() {
- # XXX: non-native tests fail if glib-networking is already installed.
- # have no idea what's wrong. would appreciate some help.
- multilib_is_native_abi || return 0
-
- virtx meson_src_test
-}
-
-multilib_src_install() {
- gnome-meson_src_install
-}
-
-pkg_postinst() {
- gnome-meson_pkg_postinst
-
- multilib_pkg_postinst() {
- gnome2_giomodule_cache_update \
- || die "Update GIO modules cache failed (for ${ABI})"
- }
- multilib_foreach_abi multilib_pkg_postinst
-}
-
-pkg_postrm() {
- gnome-meson_pkg_postrm
-
- multilib_pkg_postrm() {
- gnome2_giomodule_cache_update \
- || die "Update GIO modules cache failed (for ${ABI})"
- }
- multilib_foreach_abi multilib_pkg_postrm
-}
diff --git a/net-libs/glib-networking/metadata.xml b/net-libs/glib-networking/metadata.xml
deleted file mode 100644
index a1db58db..00000000
--- a/net-libs/glib-networking/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="libproxy">Use <pkg>net-libs/libproxy</pkg> for getting the HTTP/HTTPS/SOCKS proxy configuration</flag>
- <flag name="gnome">Extract HTTP/HTTPS/SOCKS proxy configuration stored using GSettings</flag>
- </use>
-</pkgmetadata>