summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gpe-games/xdemineur/xdemineur-2.1.1.ebuild')
-rw-r--r--gpe-games/xdemineur/xdemineur-2.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gpe-games/xdemineur/xdemineur-2.1.1.ebuild b/gpe-games/xdemineur/xdemineur-2.1.1.ebuild
new file mode 100644
index 0000000..b7359b3
--- /dev/null
+++ b/gpe-games/xdemineur/xdemineur-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+GPE_TARBALL_SUFFIX="bz2"
+GPE_MIRROR="http://gpe.linuxtogo.org/download/source"
+inherit eutils gpe
+
+DESCRIPTION="Xdemineur is a minesweeper game for the X Window System."
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+
+
+
+src_unpack() {
+ gpe_src_unpack
+}
+
+RDEPEND="${RDEPEND}"
+DEPEND=">=x11-proto/inputproto-1.4 >=x11-proto/xextproto-7.0 ${RDEPEND}"
+
+src_compile() {
+ $(tc-getCC) *.c -o xdemineur -lXpm ${CFLAGS} ${LDFLAGS}
+}
+
+src_install() {
+ mkdir -p ${D}/usr/bin/
+ cp xdemineur ${D}/usr/bin/ || die "No flow bro.."
+}