aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2010-07-07 14:22:28 +0300
committerPriit Laes <plaes@plaes.org>2010-07-07 15:28:35 +0300
commitba971b43604fcc2810acf5edfbf8a89ec2ceb540 (patch)
tree7a0731adcacf87441f2c2894bfa27f2f2c7e9e11
parentAdded Flask-based web app with Flask-SQLAlchemy dependency (diff)
downloadgsoc2010-grumpy-ba971b43604fcc2810acf5edfbf8a89ec2ceb540.tar.gz
gsoc2010-grumpy-ba971b43604fcc2810acf5edfbf8a89ec2ceb540.tar.bz2
gsoc2010-grumpy-ba971b43604fcc2810acf5edfbf8a89ec2ceb540.zip
List Flask and Flask-SQLAlchemy as dependencies, update installation docs
-rw-r--r--README6
-rw-r--r--setup.py2
2 files changed, 6 insertions, 2 deletions
diff --git a/README b/README
index 86a674c..ed9de86 100644
--- a/README
+++ b/README
@@ -11,6 +11,8 @@ Requirements
- Python-2.5+
- pkgcore
- SQLAlchemy-0.6
+ - Flask
+ - Flask-SQLAlchemy
Database support
----------------
@@ -37,8 +39,8 @@ To setup the app, you need to populate database with proper schema. So fire
up the python interpreter in the root directory of grumpy project:
$ python
- >>> from grumpy.database import init_db
- >>> init_db()
+ >>> from grumpy.models import db
+ >>> db.create_all()
If no errors were shown, then schema creation was successful :)
diff --git a/setup.py b/setup.py
index 6bcb652..4d1926d 100644
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,8 @@ setup(
zip_safe=False,
platforms='any',
install_requires=[
+ 'Flask',
+ 'Flask-SQLAlchemy',
'pkgcore',
'snakeoil',
'SQLAlchemy >= 0.6',