diff options
-rw-r--r-- | README | 6 | ||||
-rw-r--r-- | setup.py | 2 |
2 files changed, 6 insertions, 2 deletions
@@ -11,6 +11,8 @@ Requirements - Python-2.5+ - pkgcore - SQLAlchemy-0.6 + - Flask + - Flask-SQLAlchemy Database support ---------------- @@ -37,8 +39,8 @@ To setup the app, you need to populate database with proper schema. So fire up the python interpreter in the root directory of grumpy project: $ python - >>> from grumpy.database import init_db - >>> init_db() + >>> from grumpy.models import db + >>> db.create_all() If no errors were shown, then schema creation was successful :) @@ -59,6 +59,8 @@ setup( zip_safe=False, platforms='any', install_requires=[ + 'Flask', + 'Flask-SQLAlchemy', 'pkgcore', 'snakeoil', 'SQLAlchemy >= 0.6', |