aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2014-01-04 14:16:55 +0100
committerMagnus Granberg <zorry@gentoo.org>2014-01-04 14:16:55 +0100
commitb3e30af86b5440815c3b00974883f2fdd463466b (patch)
treea9ed9067daa360962c7078cc032195930aec0ae2 /upstream/configure.ac.patch
parentUpdate the doc for gcc4.9 upstream (diff)
downloadhardened-gccpatchset-master.tar.gz
hardened-gccpatchset-master.tar.bz2
hardened-gccpatchset-master.zip
Gcc 4.8.X pie version 0.5.9HEADmaster
Diffstat (limited to 'upstream/configure.ac.patch')
-rw-r--r--upstream/configure.ac.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/upstream/configure.ac.patch b/upstream/configure.ac.patch
index 2e39577..2537eeb 100644
--- a/upstream/configure.ac.patch
+++ b/upstream/configure.ac.patch
@@ -103,14 +103,14 @@
+AC_SUBST([enable_espf])
+if test $enable_espf = yes ; then
+
-+# Check for FORTIFY_SOURCES support in target C library.
-+ AC_CACHE_CHECK(for _FORTIFY_SOURCES support in target C library,
++# Check for FORTIFY_SOURCE support in target C library.
++ AC_CACHE_CHECK(for _FORTIFY_SOURCE support in target C library,
+ gcc_cv_libc_provides_fortify,
+ [gcc_cv_libc_provides_fortify=no
+ case "$target" in
+ *-*-linux*)
-+ [# glibc 2.8 and later provides _FORTIFY_SOURCES.
-+ # uClibc 0.9.32 and later provides _FORTIFY_SOURCES.
++ [# glibc 2.8 and later provides _FORTIFY_SOURCE.
++ # uClibc 0.9.32 and later provides _FORTIFY_SOURCE.
+ if test -f $target_header_dir/features.h; then
+ if $EGREP '^[ ]*#[ ]*define[ ]+__GLIBC__[ ]+2' \
+ $target_header_dir/features.h > /dev/null \
@@ -195,12 +195,12 @@
+ AC_MSG_RESULT([no])
+ fi
+
-+ AC_MSG_CHECKING(if the compiler default to use -D_FORTIFY_SOURCES=2)
++ AC_MSG_CHECKING(if the compiler default to use -D_FORTIFY_SOURCE=2)
+ if test x$gcc_cv_libc_provides_fortify = xyes && test x$cross_compiling = xno ; then
+ saved_CFLAGS="$CFLAGS"
+ saved_CPPFLAGS="$CPPFLAGS"
+ CFLAGS="$CFLAGS -O2 -Werror"
-+ CPPFLAGS="$CPPFLAGS -D_FORTIFY_SOURCES=2"
++ CPPFLAGS="$CPPFLAGS -D_FORTIFY_SOURCE=2"
+ AC_TRY_LINK([
+ #include <sys/types.h>
+ #include <sys/stat.h>
@@ -221,7 +221,7 @@
+ fi
+ if test $enable_espf_fortify = yes ; then
+ AC_DEFINE(ENABLE_ESPF_FORTIFY, 1,
-+ [Define if your compiler will default to use -D_FORTIFY_SOURCES=2.])
++ [Define if your compiler will default to use -D_FORTIFY_SOURCE=2.])
+ fi
+
+fi