summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '2.6.35/4450_check_ssp_fix.patch')
-rw-r--r--2.6.35/4450_check_ssp_fix.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/2.6.35/4450_check_ssp_fix.patch b/2.6.35/4450_check_ssp_fix.patch
new file mode 100644
index 0000000..b22bc77
--- /dev/null
+++ b/2.6.35/4450_check_ssp_fix.patch
@@ -0,0 +1,17 @@
+2010-03-31 Magnus Granberg <zorry@gentoo.org>
+
+ #312335
+ arch/x86/Makefile: Add KBUILD_CPPFLAGS to the SSP test
+ commandline for else it build that file with -fPIE
+
+--- a/arch/x86/Makefile 2010-03-31 16:39:32.000000000 +0200
++++ b/arch/x86/Makefile 2010-03-31 16:36:53.000000000 +0200
+@@ -74,7 +74,7 @@
+
+ ifdef CONFIG_CC_STACKPROTECTOR
+ cc_has_sp := $(srctree)/scripts/gcc-x86_$(BITS)-has-stack-protector.sh
+- ifeq ($(shell $(CONFIG_SHELL) $(cc_has_sp) $(CC) $(biarch)),y)
++ ifeq ($(shell $(CONFIG_SHELL) $(cc_has_sp) $(CC) $(KBUILD_CPPFLAGS) $(biarch)),y)
+ stackp-y := -fstack-protector
+ KBUILD_CFLAGS += $(stackp-y)
+ else