summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '2.6.39/4422_grsec-mute-warnings.patch')
-rw-r--r--2.6.39/4422_grsec-mute-warnings.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/2.6.39/4422_grsec-mute-warnings.patch b/2.6.39/4422_grsec-mute-warnings.patch
index 0a80640..dde08c8 100644
--- a/2.6.39/4422_grsec-mute-warnings.patch
+++ b/2.6.39/4422_grsec-mute-warnings.patch
@@ -29,14 +29,14 @@ warning flags of vanilla kernel versions.
Acked-by: Christian Heim <phreak@gentoo.org>
---
---- a/Makefile 2011-05-20 08:12:41.000000000 -0400
-+++ b/Makefile 2011-05-20 08:18:18.000000000 -0400
+--- a/Makefile 2011-06-06 00:47:21.000000000 -0400
++++ b/Makefile 2011-06-06 00:49:13.000000000 -0400
@@ -237,7 +237,7 @@
HOSTCC = gcc
HOSTCXX = g++
--HOSTCFLAGS = -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wno-empty-body -Wno-unused-parameter -Wno-missing-field-initializers -O2 -fomit-frame-pointer -fno-delete-null-pointer-checks
+-HOSTCFLAGS = -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wno-unused-parameter -Wno-missing-field-initializers -O2 -fomit-frame-pointer -fno-delete-null-pointer-checks
+HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-empty-body -Wno-unused-parameter -Wno-missing-field-initializers -O2 -fomit-frame-pointer -fno-delete-null-pointer-checks
+ HOSTCFLAGS += $(call cc-option, -Wno-empty-body)
HOSTCXXFLAGS = -O2 -fno-delete-null-pointer-checks
- # Decide whether to build built-in, modular, or both.