summaryrefslogtreecommitdiff
path: root/3.13.2
diff options
context:
space:
mode:
Diffstat (limited to '3.13.2')
-rw-r--r--3.13.2/0000_README2
-rw-r--r--3.13.2/4420_grsecurity-3.0-3.13.2-201402090002.patch (renamed from 3.13.2/4420_grsecurity-3.0-3.13.2-201402062224.patch)39
2 files changed, 21 insertions, 20 deletions
diff --git a/3.13.2/0000_README b/3.13.2/0000_README
index 850ef1e..a01567b 100644
--- a/3.13.2/0000_README
+++ b/3.13.2/0000_README
@@ -2,7 +2,7 @@ README
-----------------------------------------------------------------------------
Individual Patch Descriptions:
-----------------------------------------------------------------------------
-Patch: 4420_grsecurity-3.0-3.13.2-201402062224.patch
+Patch: 4420_grsecurity-3.0-3.13.2-201402090002.patch
From: http://www.grsecurity.net
Desc: hardened-sources base patch from upstream grsecurity
diff --git a/3.13.2/4420_grsecurity-3.0-3.13.2-201402062224.patch b/3.13.2/4420_grsecurity-3.0-3.13.2-201402090002.patch
index 824a474..76aaa29 100644
--- a/3.13.2/4420_grsecurity-3.0-3.13.2-201402062224.patch
+++ b/3.13.2/4420_grsecurity-3.0-3.13.2-201402090002.patch
@@ -1,5 +1,5 @@
diff --git a/Documentation/dontdiff b/Documentation/dontdiff
-index b89a739..31509cb 100644
+index b89a739..9aa2627 100644
--- a/Documentation/dontdiff
+++ b/Documentation/dontdiff
@@ -2,9 +2,11 @@
@@ -173,8 +173,8 @@ index b89a739..31509cb 100644
r300_reg_safe.h
r420_reg_safe.h
r600_reg_safe.h
-+randstruct.seed
-+randstruct.hashed_seed
++randomize_layout_hash.data
++randomize_layout_seed.h
+realmode.lds
+realmode.relocs
recordmcount
@@ -65436,10 +65436,10 @@ index 0000000..5307c8a
+endif
diff --git a/grsecurity/gracl.c b/grsecurity/gracl.c
new file mode 100644
-index 0000000..7232a45
+index 0000000..19a5b7c
--- /dev/null
+++ b/grsecurity/gracl.c
-@@ -0,0 +1,2677 @@
+@@ -0,0 +1,2678 @@
+#include <linux/kernel.h>
+#include <linux/module.h>
+#include <linux/sched.h>
@@ -67923,8 +67923,8 @@ index 0000000..7232a45
+void
+gr_acl_handle_psacct(struct task_struct *task, const long code)
+{
-+ unsigned long runtime;
-+ unsigned long cputime;
++ unsigned long runtime, cputime;
++ cputime_t utime, stime;
+ unsigned int wday, cday;
+ __u8 whr, chr;
+ __u8 wmin, cmin;
@@ -67937,19 +67937,20 @@ index 0000000..7232a45
+
+ do_posix_clock_monotonic_gettime(&timeval);
+ runtime = timeval.tv_sec - task->start_time.tv_sec;
-+ wday = runtime / (3600 * 24);
-+ runtime -= wday * (3600 * 24);
-+ whr = runtime / 3600;
-+ runtime -= whr * 3600;
++ wday = runtime / (60 * 60 * 24);
++ runtime -= wday * (60 * 60 * 24);
++ whr = runtime / (60 * 60);
++ runtime -= whr * (60 * 60);
+ wmin = runtime / 60;
+ runtime -= wmin * 60;
+ wsec = runtime;
+
-+ cputime = (task->utime + task->stime) / HZ;
-+ cday = cputime / (3600 * 24);
-+ cputime -= cday * (3600 * 24);
-+ chr = cputime / 3600;
-+ cputime -= chr * 3600;
++ task_cputime(task, &utime, &stime);
++ cputime = cputime_to_secs(utime + stime);
++ cday = cputime / (60 * 60 * 24);
++ cputime -= cday * (60 * 60 * 24);
++ chr = cputime / (60 * 60);
++ cputime -= chr * (60 * 60);
+ cmin = cputime / 60;
+ cputime -= cmin * 60;
+ csec = cputime;
@@ -103825,13 +103826,13 @@ index 7778b8e..3d619fc 100644
diff --git a/tools/gcc/.gitignore b/tools/gcc/.gitignore
new file mode 100644
-index 0000000..8eb55ca
+index 0000000..54052c3
--- /dev/null
+++ b/tools/gcc/.gitignore
@@ -0,0 +1,3 @@
+size_overflow_hash.h
-+randstruct.seed
-+randstruct.hashed_seed
++randomize_layout_seed.h
++randomize_layout_hash.data
diff --git a/tools/gcc/Makefile b/tools/gcc/Makefile
new file mode 100644
index 0000000..51a2ba2