summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '3.14.50/4435_grsec-mute-warnings.patch')
-rw-r--r--3.14.50/4435_grsec-mute-warnings.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/3.14.50/4435_grsec-mute-warnings.patch b/3.14.50/4435_grsec-mute-warnings.patch
new file mode 100644
index 0000000..2c2d463
--- /dev/null
+++ b/3.14.50/4435_grsec-mute-warnings.patch
@@ -0,0 +1,43 @@
+From: Anthony G. Basile <blueness@gentoo.org>
+Updated patch for 2.6.38.6
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Jory A. Pratt <anarchy@gentoo.org>
+Updated patch for kernel 2.6.32
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Gordon Malm <gengor@gentoo.org>
+
+Updated patch for kernel series 2.6.24.
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Alexander Gabert <gaberta@fh-trier.de>
+
+This patch removes the warnings introduced by grsec patch 2.1.9 and later.
+It removes the -W options added by the patch and restores the original
+warning flags of vanilla kernel versions.
+
+Acked-by: Christian Heim <phreak@gentoo.org>
+---
+
+diff -Naur a/Makefile b/Makefile
+--- a/Makefile 2015-06-27 15:35:56.363504156 -0400
++++ b/Makefile 2015-06-27 16:41:08.552598625 -0400
+@@ -244,7 +244,7 @@
+
+ HOSTCC = gcc
+ HOSTCXX = g++
+-HOSTCFLAGS = -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wno-unused-parameter -Wno-missing-field-initializers -O2 -fomit-frame-pointer -std=gnu89 -fno-delete-null-pointer-checks
++HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused-parameter -Wno-missing-field-initializers -O2 -fomit-frame-pointer -std=gnu89 -fno-delete-null-pointer-checks
+ HOSTCFLAGS += $(call cc-option, -Wno-empty-body)
+ HOSTCXXFLAGS = -O2 -Wall -W -Wno-array-bounds
+