summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '4.8.12/4435_grsec-mute-warnings.patch')
-rw-r--r--4.8.12/4435_grsec-mute-warnings.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/4.8.12/4435_grsec-mute-warnings.patch b/4.8.12/4435_grsec-mute-warnings.patch
new file mode 100644
index 0000000..8929222
--- /dev/null
+++ b/4.8.12/4435_grsec-mute-warnings.patch
@@ -0,0 +1,43 @@
+From: Anthony G. Basile <blueness@gentoo.org>
+Updated patch for 2.6.38.6
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Jory A. Pratt <anarchy@gentoo.org>
+Updated patch for kernel 2.6.32
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Gordon Malm <gengor@gentoo.org>
+
+Updated patch for kernel series 2.6.24.
+
+The credits/description from the original version of this patch remain accurate
+and are included below.
+
+---
+From: Alexander Gabert <gaberta@fh-trier.de>
+
+This patch removes the warnings introduced by grsec patch 2.1.9 and later.
+It removes the -W options added by the patch and restores the original
+warning flags of vanilla kernel versions.
+
+Acked-by: Christian Heim <phreak@gentoo.org>
+---
+
+diff -Naur linux-4.0.2-hardened.orig/Makefile linux-4.0.2-hardened/Makefile
+--- linux-4.0.2-hardened.orig/Makefile 2015-05-09 21:08:19.243113731 -0400
++++ linux-4.0.2-hardened/Makefile 2015-05-09 21:10:37.775120037 -0400
+@@ -302,7 +302,7 @@
+ HOSTCC = gcc
+ HOSTCXX = g++
+ HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu89
+-HOSTCFLAGS = -W -Wno-unused-parameter -Wno-missing-field-initializers -fno-delete-null-pointer-checks
++HOSTCFLAGS = -Wno-unused-parameter -Wno-missing-field-initializers -fno-delete-null-pointer-checks
+ HOSTCFLAGS += $(call cc-option, -Wno-empty-body)
+ HOSTCXXFLAGS = -O2 -Wall -W -Wno-array-bounds
+