summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--4.5.7/0000_README (renamed from 4.5.6/0000_README)2
-rw-r--r--4.5.7/4420_grsecurity-3.1-4.5.7-201606080852.patch (renamed from 4.5.6/4420_grsecurity-3.1-4.5.6-201606051644.patch)172
-rw-r--r--4.5.7/4425_grsec_remove_EI_PAX.patch (renamed from 4.5.6/4425_grsec_remove_EI_PAX.patch)0
-rw-r--r--4.5.7/4427_force_XATTR_PAX_tmpfs.patch (renamed from 4.5.6/4427_force_XATTR_PAX_tmpfs.patch)0
-rw-r--r--4.5.7/4430_grsec-remove-localversion-grsec.patch (renamed from 4.5.6/4430_grsec-remove-localversion-grsec.patch)0
-rw-r--r--4.5.7/4435_grsec-mute-warnings.patch (renamed from 4.5.6/4435_grsec-mute-warnings.patch)0
-rw-r--r--4.5.7/4440_grsec-remove-protected-paths.patch (renamed from 4.5.6/4440_grsec-remove-protected-paths.patch)0
-rw-r--r--4.5.7/4450_grsec-kconfig-default-gids.patch (renamed from 4.5.6/4450_grsec-kconfig-default-gids.patch)0
-rw-r--r--4.5.7/4465_selinux-avc_audit-log-curr_ip.patch (renamed from 4.5.6/4465_selinux-avc_audit-log-curr_ip.patch)0
-rw-r--r--4.5.7/4470_disable-compat_vdso.patch (renamed from 4.5.6/4470_disable-compat_vdso.patch)0
-rw-r--r--4.5.7/4475_emutramp_default_on.patch (renamed from 4.5.6/4475_emutramp_default_on.patch)0
11 files changed, 87 insertions, 87 deletions
diff --git a/4.5.6/0000_README b/4.5.7/0000_README
index 48f38a5..67f12a7 100644
--- a/4.5.6/0000_README
+++ b/4.5.7/0000_README
@@ -2,7 +2,7 @@ README
-----------------------------------------------------------------------------
Individual Patch Descriptions:
-----------------------------------------------------------------------------
-Patch: 4420_grsecurity-3.1-4.5.6-201606051644.patch
+Patch: 4420_grsecurity-3.1-4.5.7-201606080852.patch
From: http://www.grsecurity.net
Desc: hardened-sources base patch from upstream grsecurity
diff --git a/4.5.6/4420_grsecurity-3.1-4.5.6-201606051644.patch b/4.5.7/4420_grsecurity-3.1-4.5.7-201606080852.patch
index d2dfe90..65f5e28 100644
--- a/4.5.6/4420_grsecurity-3.1-4.5.6-201606051644.patch
+++ b/4.5.7/4420_grsecurity-3.1-4.5.7-201606080852.patch
@@ -408,7 +408,7 @@ index a93b414..f50a50b 100644
A toggle value indicating if modules are allowed to be loaded
diff --git a/Makefile b/Makefile
-index 07a1786..7f359da 100644
+index 90e4bd9..44d0d41 100644
--- a/Makefile
+++ b/Makefile
@@ -298,7 +298,9 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
@@ -6426,7 +6426,7 @@ index b336037..5b874cc 100644
/*
diff --git a/arch/mips/include/asm/pgtable.h b/arch/mips/include/asm/pgtable.h
-index 9a4fe01..3aa92e9 100644
+index 65bf2c0..09b7819 100644
--- a/arch/mips/include/asm/pgtable.h
+++ b/arch/mips/include/asm/pgtable.h
@@ -20,6 +20,9 @@
@@ -6598,7 +6598,7 @@ index f63a289..53037c22 100644
/* Run the generated entry code */
diff --git a/arch/mips/kernel/process.c b/arch/mips/kernel/process.c
-index eddd5fd..97314be 100644
+index 0c0456f..fdb287a3 100644
--- a/arch/mips/kernel/process.c
+++ b/arch/mips/kernel/process.c
@@ -539,18 +539,6 @@ out:
@@ -6621,10 +6621,10 @@ index eddd5fd..97314be 100644
{
struct pt_regs *regs;
diff --git a/arch/mips/kernel/ptrace.c b/arch/mips/kernel/ptrace.c
-index a5279b2..50b73be 100644
+index 4285d8b..febcfeb 100644
--- a/arch/mips/kernel/ptrace.c
+++ b/arch/mips/kernel/ptrace.c
-@@ -870,6 +870,10 @@ long arch_ptrace(struct task_struct *child, long request,
+@@ -881,6 +881,10 @@ long arch_ptrace(struct task_struct *child, long request,
return ret;
}
@@ -6635,7 +6635,7 @@ index a5279b2..50b73be 100644
/*
* Notification of system call entry/exit
* - triggered by current->work.syscall_trace
-@@ -888,6 +892,11 @@ asmlinkage long syscall_trace_enter(struct pt_regs *regs, long syscall)
+@@ -899,6 +903,11 @@ asmlinkage long syscall_trace_enter(struct pt_regs *regs, long syscall)
tracehook_report_syscall_entry(regs))
ret = -1;
@@ -6717,7 +6717,7 @@ index 4472a7f..c5905e6 100644
}
/* Arrange for an interrupt in a short while */
diff --git a/arch/mips/kernel/traps.c b/arch/mips/kernel/traps.c
-index bf14da9..d1e0ded 100644
+index 58a7cad..315d7bc 100644
--- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c
@@ -697,7 +697,18 @@ asmlinkage void do_ov(struct pt_regs *regs)
@@ -6741,23 +6741,23 @@ index bf14da9..d1e0ded 100644
force_sig_info(SIGFPE, &info, current);
exception_exit(prev_state);
diff --git a/arch/mips/lib/ashldi3.c b/arch/mips/lib/ashldi3.c
-index beb80f31..4809f0b 100644
+index 927dc94..27269ee 100644
--- a/arch/mips/lib/ashldi3.c
+++ b/arch/mips/lib/ashldi3.c
@@ -2,7 +2,11 @@
#include "libgcc.h"
--long long __ashldi3(long long u, word_type b)
+-long long notrace __ashldi3(long long u, word_type b)
+#ifdef CONFIG_64BIT
-+DWtype __ashlti3(DWtype u, word_type b)
++DWtype notrace __ashlti3(DWtype u, word_type b)
+#else
-+DWtype __ashldi3(DWtype u, word_type b)
++DWtype notrace __ashldi3(DWtype u, word_type b)
+#endif
{
DWunion uu, w;
word_type bm;
-@@ -11,19 +15,22 @@ long long __ashldi3(long long u, word_type b)
+@@ -11,19 +15,22 @@ long long notrace __ashldi3(long long u, word_type b)
return u;
uu.ll = u;
@@ -6787,23 +6787,23 @@ index beb80f31..4809f0b 100644
EXPORT_SYMBOL(__ashldi3);
+#endif
diff --git a/arch/mips/lib/ashrdi3.c b/arch/mips/lib/ashrdi3.c
-index c884a91..3c4ff03 100644
+index 9fdf1a5..6741f0e 100644
--- a/arch/mips/lib/ashrdi3.c
+++ b/arch/mips/lib/ashrdi3.c
@@ -2,7 +2,11 @@
#include "libgcc.h"
--long long __ashrdi3(long long u, word_type b)
+-long long notrace __ashrdi3(long long u, word_type b)
+#ifdef CONFIG_64BIT
-+DWtype __ashrti3(DWtype u, word_type b)
++DWtype notrace __ashrti3(DWtype u, word_type b)
+#else
-+DWtype __ashrdi3(DWtype u, word_type b)
++DWtype notrace __ashrdi3(DWtype u, word_type b)
+#endif
{
DWunion uu, w;
word_type bm;
-@@ -11,21 +15,24 @@ long long __ashrdi3(long long u, word_type b)
+@@ -11,21 +15,24 @@ long long notrace __ashrdi3(long long u, word_type b)
return u;
uu.ll = u;
@@ -8741,10 +8741,10 @@ index 488e631..6cdd928 100644
ld r4,_DAR(r1)
bl bad_page_fault
diff --git a/arch/powerpc/kernel/exceptions-64s.S b/arch/powerpc/kernel/exceptions-64s.S
-index 7716ceb..6018173 100644
+index 2b66f25..80884d4 100644
--- a/arch/powerpc/kernel/exceptions-64s.S
+++ b/arch/powerpc/kernel/exceptions-64s.S
-@@ -1572,10 +1572,10 @@ handle_page_fault:
+@@ -1578,10 +1578,10 @@ handle_page_fault:
11: ld r4,_DAR(r1)
ld r5,_DSISR(r1)
addi r3,r1,STACK_FRAME_OVERHEAD
@@ -41217,7 +41217,7 @@ index 0caf92a..62c184c 100644
mutex_lock(&pd->lock);
ret = genpd_poweron(pd, 0);
diff --git a/drivers/base/power/runtime.c b/drivers/base/power/runtime.c
-index 4c70550..223bba1 100644
+index b746904..10c39fe 100644
--- a/drivers/base/power/runtime.c
+++ b/drivers/base/power/runtime.c
@@ -16,35 +16,32 @@
@@ -45007,7 +45007,7 @@ index 75cb5b9..2f6481f 100644
void *amdgpu_cgs_create_device(struct amdgpu_device *adev)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c
-index 119cdc2..fd6698c 100644
+index 7ef2c13..dff07e5 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c
@@ -701,7 +701,7 @@ static int amdgpu_connector_lvds_get_modes(struct drm_connector *connector)
@@ -45732,7 +45732,7 @@ index 2849f1b..86f509b 100644
{
struct bochs_device *bochs =
diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
-index 9a7b446..33576d3 100644
+index ee9914d..e028752 100644
--- a/drivers/gpu/drm/drm_atomic.c
+++ b/drivers/gpu/drm/drm_atomic.c
@@ -1339,6 +1339,11 @@ EXPORT_SYMBOL(drm_atomic_async_commit);
@@ -46690,10 +46690,10 @@ index fa8afa7..7375300 100644
/**
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
-index 39b00b9..244538d 100644
+index 207391e..fda2cb4 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
-@@ -15111,13 +15111,13 @@ struct intel_quirk {
+@@ -15120,13 +15120,13 @@ struct intel_quirk {
int subsystem_vendor;
int subsystem_device;
void (*hook)(struct drm_device *dev);
@@ -46710,7 +46710,7 @@ index 39b00b9..244538d 100644
static int intel_dmi_reverse_brightness(const struct dmi_system_id *id)
{
-@@ -15125,18 +15125,20 @@ static int intel_dmi_reverse_brightness(const struct dmi_system_id *id)
+@@ -15134,18 +15134,20 @@ static int intel_dmi_reverse_brightness(const struct dmi_system_id *id)
return 1;
}
@@ -46741,7 +46741,7 @@ index 39b00b9..244538d 100644
.hook = quirk_invert_brightness,
},
};
-@@ -15219,7 +15221,7 @@ static void intel_init_quirks(struct drm_device *dev)
+@@ -15228,7 +15230,7 @@ static void intel_init_quirks(struct drm_device *dev)
q->hook(dev);
}
for (i = 0; i < ARRAY_SIZE(intel_dmi_quirks); i++) {
@@ -46751,10 +46751,10 @@ index 39b00b9..244538d 100644
}
}
diff --git a/drivers/gpu/drm/imx/imx-drm-core.c b/drivers/gpu/drm/imx/imx-drm-core.c
-index 2f57d79..7152e6e 100644
+index 286f539..f900163 100644
--- a/drivers/gpu/drm/imx/imx-drm-core.c
+++ b/drivers/gpu/drm/imx/imx-drm-core.c
-@@ -348,7 +348,7 @@ int imx_drm_add_crtc(struct drm_device *drm, struct drm_crtc *crtc,
+@@ -349,7 +349,7 @@ int imx_drm_add_crtc(struct drm_device *drm, struct drm_crtc *crtc,
if (imxdrm->pipes >= MAX_CRTC)
return -EINVAL;
@@ -56448,10 +56448,10 @@ index 5b80850..97b8443 100644
spi = spi_new_device(master, info);
diff --git a/drivers/media/v4l2-core/v4l2-compat-ioctl32.c b/drivers/media/v4l2-core/v4l2-compat-ioctl32.c
-index 019644f..a988084 100644
+index bacecbd..277d1f8 100644
--- a/drivers/media/v4l2-core/v4l2-compat-ioctl32.c
+++ b/drivers/media/v4l2-core/v4l2-compat-ioctl32.c
-@@ -448,7 +448,7 @@ static int get_v4l2_buffer32(struct v4l2_buffer *kp, struct v4l2_buffer32 __user
+@@ -449,7 +449,7 @@ static int get_v4l2_buffer32(struct v4l2_buffer *kp, struct v4l2_buffer32 __user
* by passing a very big num_planes value */
uplane = compat_alloc_user_space(num_planes *
sizeof(struct v4l2_plane));
@@ -56460,7 +56460,7 @@ index 019644f..a988084 100644
while (--num_planes >= 0) {
ret = get_v4l2_plane32(uplane, uplane32, kp->memory);
-@@ -518,7 +518,7 @@ static int put_v4l2_buffer32(struct v4l2_buffer *kp, struct v4l2_buffer32 __user
+@@ -519,7 +519,7 @@ static int put_v4l2_buffer32(struct v4l2_buffer *kp, struct v4l2_buffer32 __user
if (num_planes == 0)
return 0;
@@ -56469,7 +56469,7 @@ index 019644f..a988084 100644
if (get_user(p, &up->m.planes))
return -EFAULT;
uplane32 = compat_ptr(p);
-@@ -580,7 +580,7 @@ static int get_v4l2_framebuffer32(struct v4l2_framebuffer *kp, struct v4l2_frame
+@@ -581,7 +581,7 @@ static int get_v4l2_framebuffer32(struct v4l2_framebuffer *kp, struct v4l2_frame
get_user(kp->flags, &up->flags) ||
copy_from_user(&kp->fmt, &up->fmt, sizeof(up->fmt)))
return -EFAULT;
@@ -56478,7 +56478,7 @@ index 019644f..a988084 100644
return 0;
}
-@@ -686,7 +686,7 @@ static int get_v4l2_ext_controls32(struct v4l2_ext_controls *kp, struct v4l2_ext
+@@ -687,7 +687,7 @@ static int get_v4l2_ext_controls32(struct v4l2_ext_controls *kp, struct v4l2_ext
n * sizeof(struct v4l2_ext_control32)))
return -EFAULT;
kcontrols = compat_alloc_user_space(n * sizeof(struct v4l2_ext_control));
@@ -56487,7 +56487,7 @@ index 019644f..a988084 100644
while (--n >= 0) {
u32 id;
-@@ -713,7 +713,7 @@ static int put_v4l2_ext_controls32(struct v4l2_ext_controls *kp, struct v4l2_ext
+@@ -714,7 +714,7 @@ static int put_v4l2_ext_controls32(struct v4l2_ext_controls *kp, struct v4l2_ext
{
struct v4l2_ext_control32 __user *ucontrols;
struct v4l2_ext_control __user *kcontrols =
@@ -56496,7 +56496,7 @@ index 019644f..a988084 100644
int n = kp->count;
compat_caddr_t p;
-@@ -798,7 +798,7 @@ static int get_v4l2_edid32(struct v4l2_edid *kp, struct v4l2_edid32 __user *up)
+@@ -799,7 +799,7 @@ static int get_v4l2_edid32(struct v4l2_edid *kp, struct v4l2_edid32 __user *up)
get_user(tmp, &up->edid) ||
copy_from_user(kp->reserved, up->reserved, sizeof(kp->reserved)))
return -EFAULT;
@@ -66555,7 +66555,7 @@ index 7bbc869..d69e243 100644
u32 reg;
diff --git a/drivers/net/wireless/realtek/rtlwifi/base.c b/drivers/net/wireless/realtek/rtlwifi/base.c
-index 0517a4f..cac8e6b 100644
+index 7a40d8d..09b0e06 100644
--- a/drivers/net/wireless/realtek/rtlwifi/base.c
+++ b/drivers/net/wireless/realtek/rtlwifi/base.c
@@ -467,15 +467,15 @@ static void _rtl_init_deferred_work(struct ieee80211_hw *hw)
@@ -66613,7 +66613,7 @@ index 74233d6..482e495 100644
void rtl_get_tcb_desc(struct ieee80211_hw *hw,
struct ieee80211_tx_info *info,
diff --git a/drivers/net/wireless/realtek/rtlwifi/pci.c b/drivers/net/wireless/realtek/rtlwifi/pci.c
-index 7f471bf..de826f0 100644
+index 5b40480..39d6d27 100644
--- a/drivers/net/wireless/realtek/rtlwifi/pci.c
+++ b/drivers/net/wireless/realtek/rtlwifi/pci.c
@@ -1100,13 +1100,16 @@ done:
@@ -67752,12 +67752,12 @@ index be35da2..ec16cdb 100644
* Boxes that should not use MSI for PCIe PME signaling.
*/
diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
-index 6b0056e..c8105d5 100644
+index 6e3feec..b3721b0 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
-@@ -182,7 +182,7 @@ int __pci_read_base(struct pci_dev *dev, enum pci_bar_type type,
- if (dev->non_compliant_bars)
- return 0;
+@@ -179,7 +179,7 @@ int __pci_read_base(struct pci_dev *dev, enum pci_bar_type type,
+ u16 orig_cmd;
+ struct pci_bus_region region, inverted_region;
- mask = type ? PCI_ROM_ADDRESS_MASK : ~0;
+ mask = type ? (u32)PCI_ROM_ADDRESS_MASK : ~0;
@@ -81765,10 +81765,10 @@ index 3c14e43..2630570 100644
+4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4
+4 4 4 4 4 4
diff --git a/drivers/xen/events/events_base.c b/drivers/xen/events/events_base.c
-index 4436778..bfcd027 100644
+index 83ec7b8..bf1cce8 100644
--- a/drivers/xen/events/events_base.c
+++ b/drivers/xen/events/events_base.c
-@@ -1585,7 +1585,7 @@ void xen_irq_resume(void)
+@@ -1587,7 +1587,7 @@ void xen_irq_resume(void)
restore_pirqs();
}
@@ -81777,7 +81777,7 @@ index 4436778..bfcd027 100644
.name = "xen-dyn",
.irq_disable = disable_dynirq,
-@@ -1599,7 +1599,7 @@ static struct irq_chip xen_dynamic_chip __read_mostly = {
+@@ -1601,7 +1601,7 @@ static struct irq_chip xen_dynamic_chip __read_mostly = {
.irq_retrigger = retrigger_dynirq,
};
@@ -81786,7 +81786,7 @@ index 4436778..bfcd027 100644
.name = "xen-pirq",
.irq_startup = startup_pirq,
-@@ -1619,7 +1619,7 @@ static struct irq_chip xen_pirq_chip __read_mostly = {
+@@ -1621,7 +1621,7 @@ static struct irq_chip xen_pirq_chip __read_mostly = {
.irq_retrigger = retrigger_dynirq,
};
@@ -95498,7 +95498,7 @@ index dea6486..32f1db9 100644
WARN_ON(trans->transid != btrfs_header_generation(parent));
diff --git a/fs/btrfs/ctree.h b/fs/btrfs/ctree.h
-index 6661ad8..11c47b3 100644
+index 7c9a9c0..496d164 100644
--- a/fs/btrfs/ctree.h
+++ b/fs/btrfs/ctree.h
@@ -1618,7 +1618,7 @@ struct btrfs_fs_info {
@@ -95643,7 +95643,7 @@ index 84fb56d..ee0fe69 100644
RB_CLEAR_NODE(&merge->rb_node);
em->mod_len = (merge->mod_start + merge->mod_len) - em->mod_start;
diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
-index 5d956b8..38741ed 100644
+index 187fa7b..91e7c7f 100644
--- a/fs/btrfs/file.c
+++ b/fs/btrfs/file.c
@@ -1910,7 +1910,7 @@ int btrfs_sync_file(struct file *file, loff_t start, loff_t end, int datasync)
@@ -95812,7 +95812,7 @@ index 5516136..8480a2f 100644
* build a list of bios to read all the missing parts of this
* stripe
diff --git a/fs/btrfs/super.c b/fs/btrfs/super.c
-index d41e09fe..0a20548 100644
+index 468e988..7ac7d59 100644
--- a/fs/btrfs/super.c
+++ b/fs/btrfs/super.c
@@ -248,7 +248,7 @@ void __btrfs_abort_transaction(struct btrfs_trans_handle *trans,
@@ -95825,10 +95825,10 @@ index d41e09fe..0a20548 100644
wake_up(&root->fs_info->transaction_wait);
wake_up(&root->fs_info->transaction_blocked_wait);
diff --git a/fs/btrfs/sysfs.c b/fs/btrfs/sysfs.c
-index 539e7b5..9de4167 100644
+index 3d14618..fe5cc46 100644
--- a/fs/btrfs/sysfs.c
+++ b/fs/btrfs/sysfs.c
-@@ -483,7 +483,7 @@ static int addrm_unknown_feature_attrs(struct btrfs_fs_info *fs_info, bool add)
+@@ -489,7 +489,7 @@ static int addrm_unknown_feature_attrs(struct btrfs_fs_info *fs_info, bool add)
for (set = 0; set < FEAT_MAX; set++) {
int i;
struct attribute *attrs[2];
@@ -95877,7 +95877,7 @@ index b6031ce..5d53523 100644
spin_lock_init(&cur_trans->delayed_refs.lock);
diff --git a/fs/btrfs/tree-log.c b/fs/btrfs/tree-log.c
-index 58ae0a2..94e8de6 100644
+index a2cd421..a5ce86c 100644
--- a/fs/btrfs/tree-log.c
+++ b/fs/btrfs/tree-log.c
@@ -172,7 +172,7 @@ static int start_log_trans(struct btrfs_trans_handle *trans,
@@ -95930,7 +95930,7 @@ index a9f1b75..0df211d 100644
static inline int btrfs_need_log_full_commit(struct btrfs_fs_info *fs_info,
diff --git a/fs/btrfs/volumes.c b/fs/btrfs/volumes.c
-index 366b335..54dba62 100644
+index 542c043..95d562d 100644
--- a/fs/btrfs/volumes.c
+++ b/fs/btrfs/volumes.c
@@ -232,7 +232,7 @@ static struct btrfs_device *__alloc_device(void)
@@ -95942,7 +95942,7 @@ index 366b335..54dba62 100644
btrfs_device_data_ordered_init(dev);
INIT_RADIX_TREE(&dev->reada_zones, GFP_NOFS & ~__GFP_DIRECT_RECLAIM);
INIT_RADIX_TREE(&dev->reada_extents, GFP_NOFS & ~__GFP_DIRECT_RECLAIM);
-@@ -5197,7 +5197,7 @@ static struct btrfs_bio *alloc_btrfs_bio(int total_stripes, int real_stripes)
+@@ -5210,7 +5210,7 @@ static struct btrfs_bio *alloc_btrfs_bio(int total_stripes, int real_stripes)
sizeof(u64) * (total_stripes),
GFP_NOFS|__GFP_NOFAIL);
@@ -95951,7 +95951,7 @@ index 366b335..54dba62 100644
atomic_set(&bbio->refs, 1);
return bbio;
-@@ -5876,7 +5876,7 @@ static void btrfs_end_bio(struct bio *bio)
+@@ -5903,7 +5903,7 @@ static void btrfs_end_bio(struct bio *bio)
int is_orig_bio = 0;
if (bio->bi_error) {
@@ -95960,7 +95960,7 @@ index 366b335..54dba62 100644
if (bio->bi_error == -EIO || bio->bi_error == -EREMOTEIO) {
unsigned int stripe_index =
btrfs_io_bio(bio)->stripe_index;
-@@ -5914,7 +5914,7 @@ static void btrfs_end_bio(struct bio *bio)
+@@ -5941,7 +5941,7 @@ static void btrfs_end_bio(struct bio *bio)
/* only send an error to the higher layers if it is
* beyond the tolerance of the btrfs bio
*/
@@ -95969,7 +95969,7 @@ index 366b335..54dba62 100644
bio->bi_error = -EIO;
} else {
/*
-@@ -6025,7 +6025,7 @@ static void submit_stripe_bio(struct btrfs_root *root, struct btrfs_bio *bbio,
+@@ -6052,7 +6052,7 @@ static void submit_stripe_bio(struct btrfs_root *root, struct btrfs_bio *bbio,
static void bbio_error(struct btrfs_bio *bbio, struct bio *bio, u64 logical)
{
@@ -95978,7 +95978,7 @@ index 366b335..54dba62 100644
if (atomic_dec_and_test(&bbio->stripes_pending)) {
/* Shoud be the original bio. */
WARN_ON(bio != bbio->orig_bio);
-@@ -6822,10 +6822,10 @@ int btrfs_run_dev_stats(struct btrfs_trans_handle *trans,
+@@ -6849,10 +6849,10 @@ int btrfs_run_dev_stats(struct btrfs_trans_handle *trans,
if (!device->dev_stats_valid || !btrfs_dev_stats_dirty(device))
continue;
@@ -95992,7 +95992,7 @@ index 366b335..54dba62 100644
mutex_unlock(&fs_devices->device_list_mutex);
diff --git a/fs/btrfs/volumes.h b/fs/btrfs/volumes.h
-index 1939ebd..2330751 100644
+index 7507be7..f60446c 100644
--- a/fs/btrfs/volumes.h
+++ b/fs/btrfs/volumes.h
@@ -148,8 +148,8 @@ struct btrfs_device {
@@ -98484,10 +98484,10 @@ index 3753ceb..bddcd49 100644
eh = ext_inode_hdr(inode);
diff --git a/fs/ext4/mballoc.c b/fs/ext4/mballoc.c
-index 4424b7b..c47c8ff 100644
+index da07228..6845593 100644
--- a/fs/ext4/mballoc.c
+++ b/fs/ext4/mballoc.c
-@@ -1912,7 +1912,7 @@ void ext4_mb_simple_scan_group(struct ext4_allocation_context *ac,
+@@ -1914,7 +1914,7 @@ void ext4_mb_simple_scan_group(struct ext4_allocation_context *ac,
BUG_ON(ac->ac_b_ex.fe_len != ac->ac_g_ex.fe_len);
if (EXT4_SB(sb)->s_mb_stats)
@@ -98496,7 +98496,7 @@ index 4424b7b..c47c8ff 100644
break;
}
-@@ -2235,7 +2235,7 @@ repeat:
+@@ -2237,7 +2237,7 @@ repeat:
ac->ac_status = AC_STATUS_CONTINUE;
ac->ac_flags |= EXT4_MB_HINT_FIRST;
cr = 3;
@@ -98505,7 +98505,7 @@ index 4424b7b..c47c8ff 100644
goto repeat;
}
}
-@@ -2732,25 +2732,25 @@ int ext4_mb_release(struct super_block *sb)
+@@ -2736,25 +2736,25 @@ int ext4_mb_release(struct super_block *sb)
if (sbi->s_mb_stats) {
ext4_msg(sb, KERN_INFO,
"mballoc: %u blocks %u reqs (%u success)",
@@ -98541,7 +98541,7 @@ index 4424b7b..c47c8ff 100644
}
free_percpu(sbi->s_locality_groups);
-@@ -3208,16 +3208,16 @@ static void ext4_mb_collect_stats(struct ext4_allocation_context *ac)
+@@ -3212,16 +3212,16 @@ static void ext4_mb_collect_stats(struct ext4_allocation_context *ac)
struct ext4_sb_info *sbi = EXT4_SB(ac->ac_sb);
if (sbi->s_mb_stats && ac->ac_g_ex.fe_len > 1) {
@@ -98564,7 +98564,7 @@ index 4424b7b..c47c8ff 100644
}
if (ac->ac_op == EXT4_MB_HISTORY_ALLOC)
-@@ -3644,7 +3644,7 @@ ext4_mb_new_inode_pa(struct ext4_allocation_context *ac)
+@@ -3648,7 +3648,7 @@ ext4_mb_new_inode_pa(struct ext4_allocation_context *ac)
trace_ext4_mb_new_inode_pa(ac, pa);
ext4_mb_use_inode_pa(ac, pa);
@@ -98573,7 +98573,7 @@ index 4424b7b..c47c8ff 100644
ei = EXT4_I(ac->ac_inode);
grp = ext4_get_group_info(sb, ac->ac_b_ex.fe_group);
-@@ -3704,7 +3704,7 @@ ext4_mb_new_group_pa(struct ext4_allocation_context *ac)
+@@ -3708,7 +3708,7 @@ ext4_mb_new_group_pa(struct ext4_allocation_context *ac)
trace_ext4_mb_new_group_pa(ac, pa);
ext4_mb_use_group_pa(ac, pa);
@@ -98582,7 +98582,7 @@ index 4424b7b..c47c8ff 100644
grp = ext4_get_group_info(sb, ac->ac_b_ex.fe_group);
lg = ac->ac_lg;
-@@ -3793,7 +3793,7 @@ ext4_mb_release_inode_pa(struct ext4_buddy *e4b, struct buffer_head *bitmap_bh,
+@@ -3797,7 +3797,7 @@ ext4_mb_release_inode_pa(struct ext4_buddy *e4b, struct buffer_head *bitmap_bh,
* from the bitmap and continue.
*/
}
@@ -98591,7 +98591,7 @@ index 4424b7b..c47c8ff 100644
return err;
}
-@@ -3811,7 +3811,7 @@ ext4_mb_release_group_pa(struct ext4_buddy *e4b,
+@@ -3815,7 +3815,7 @@ ext4_mb_release_group_pa(struct ext4_buddy *e4b,
ext4_get_group_no_and_offset(sb, pa->pa_pstart, &group, &bit);
BUG_ON(group != e4b->bd_group && pa->pa_len != 0);
mb_free_blocks(pa->pa_inode, e4b, bit, pa->pa_len);
@@ -127580,7 +127580,7 @@ index afc1343..9735539 100644
extern int blk_trace_ioctl(struct block_device *, unsigned, char __user *);
diff --git a/include/linux/cache.h b/include/linux/cache.h
-index 17e7e82..1d7da26 100644
+index 17e7e82d..1d7da26 100644
--- a/include/linux/cache.h
+++ b/include/linux/cache.h
@@ -16,6 +16,14 @@
@@ -131044,7 +131044,7 @@ index 2696c1f..9320d41 100644
static inline int
vma_dup_policy(struct vm_area_struct *src, struct vm_area_struct *dst)
diff --git a/include/linux/mm.h b/include/linux/mm.h
-index e4e59f9..e23d329 100644
+index 5eaac6d..97f1585 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -155,6 +155,11 @@ extern unsigned int kobjsize(const void *objp);
@@ -138199,7 +138199,7 @@ index 0167679..f0336a8 100644
pagefault_disable();
result = __copy_from_user_inatomic(&opcode, (void __user*)vaddr,
diff --git a/kernel/exit.c b/kernel/exit.c
-index 10e0882..afcc374 100644
+index c112abb..49d919f 100644
--- a/kernel/exit.c
+++ b/kernel/exit.c
@@ -169,6 +169,10 @@ void release_task(struct task_struct *p)
@@ -138269,7 +138269,7 @@ index 10e0882..afcc374 100644
do_group_exit(int exit_code)
{
struct signal_struct *sig = current->signal;
-@@ -966,6 +975,7 @@ static int wait_noreap_copyout(struct wait_opts *wo, struct task_struct *p,
+@@ -977,6 +986,7 @@ static int wait_noreap_copyout(struct wait_opts *wo, struct task_struct *p,
* the lock and this task is uninteresting. If we return nonzero, we have
* released the lock and the system call should return.
*/
@@ -138277,7 +138277,7 @@ index 10e0882..afcc374 100644
static int wait_task_zombie(struct wait_opts *wo, struct task_struct *p)
{
int state, retval, status;
-@@ -982,6 +992,7 @@ static int wait_task_zombie(struct wait_opts *wo, struct task_struct *p)
+@@ -993,6 +1003,7 @@ static int wait_task_zombie(struct wait_opts *wo, struct task_struct *p)
get_task_struct(p);
read_unlock(&tasklist_lock);
@@ -138285,7 +138285,7 @@ index 10e0882..afcc374 100644
sched_annotate_sleep();
if ((exit_code & 0x7f) == 0) {
-@@ -1004,6 +1015,7 @@ static int wait_task_zombie(struct wait_opts *wo, struct task_struct *p)
+@@ -1015,6 +1026,7 @@ static int wait_task_zombie(struct wait_opts *wo, struct task_struct *p)
* We own this thread, nobody else can reap it.
*/
read_unlock(&tasklist_lock);
@@ -138293,7 +138293,7 @@ index 10e0882..afcc374 100644
sched_annotate_sleep();
/*
-@@ -1146,6 +1158,8 @@ static int *task_stopped_code(struct task_struct *p, bool ptrace)
+@@ -1157,6 +1169,8 @@ static int *task_stopped_code(struct task_struct *p, bool ptrace)
* search should terminate.
*/
static int wait_task_stopped(struct wait_opts *wo,
@@ -138302,7 +138302,7 @@ index 10e0882..afcc374 100644
int ptrace, struct task_struct *p)
{
struct siginfo __user *infop;
-@@ -1193,6 +1207,7 @@ unlock_sig:
+@@ -1204,6 +1218,7 @@ unlock_sig:
pid = task_pid_vnr(p);
why = ptrace ? CLD_TRAPPED : CLD_STOPPED;
read_unlock(&tasklist_lock);
@@ -138310,7 +138310,7 @@ index 10e0882..afcc374 100644
sched_annotate_sleep();
if (unlikely(wo->wo_flags & WNOWAIT))
-@@ -1230,6 +1245,7 @@ unlock_sig:
+@@ -1241,6 +1256,7 @@ unlock_sig:
* the lock and this task is uninteresting. If we return nonzero, we have
* released the lock and the system call should return.
*/
@@ -138318,7 +138318,7 @@ index 10e0882..afcc374 100644
static int wait_task_continued(struct wait_opts *wo, struct task_struct *p)
{
int retval;
-@@ -1256,6 +1272,7 @@ static int wait_task_continued(struct wait_opts *wo, struct task_struct *p)
+@@ -1267,6 +1283,7 @@ static int wait_task_continued(struct wait_opts *wo, struct task_struct *p)
pid = task_pid_vnr(p);
get_task_struct(p);
read_unlock(&tasklist_lock);
@@ -138326,7 +138326,7 @@ index 10e0882..afcc374 100644
sched_annotate_sleep();
if (!wo->wo_info) {
-@@ -1285,6 +1302,8 @@ static int wait_task_continued(struct wait_opts *wo, struct task_struct *p)
+@@ -1296,6 +1313,8 @@ static int wait_task_continued(struct wait_opts *wo, struct task_struct *p)
* or another error from security_task_wait(), or still -ECHILD.
*/
static int wait_consider_task(struct wait_opts *wo, int ptrace,
@@ -138335,7 +138335,7 @@ index 10e0882..afcc374 100644
struct task_struct *p)
{
/*
-@@ -1410,6 +1429,7 @@ static int wait_consider_task(struct wait_opts *wo, int ptrace,
+@@ -1421,6 +1440,7 @@ static int wait_consider_task(struct wait_opts *wo, int ptrace,
* ->notask_error is 0 if there were any eligible children,
* or another error from security_task_wait(), or still -ECHILD.
*/
@@ -138343,7 +138343,7 @@ index 10e0882..afcc374 100644
static int do_wait_thread(struct wait_opts *wo, struct task_struct *tsk)
{
struct task_struct *p;
-@@ -1424,6 +1444,7 @@ static int do_wait_thread(struct wait_opts *wo, struct task_struct *tsk)
+@@ -1435,6 +1455,7 @@ static int do_wait_thread(struct wait_opts *wo, struct task_struct *tsk)
return 0;
}
@@ -138351,7 +138351,7 @@ index 10e0882..afcc374 100644
static int ptrace_do_wait(struct wait_opts *wo, struct task_struct *tsk)
{
struct task_struct *p;
-@@ -1487,12 +1508,16 @@ repeat:
+@@ -1498,12 +1519,16 @@ repeat:
tsk = current;
do {
retval = do_wait_thread(wo, tsk);
@@ -144450,7 +144450,7 @@ index 7f34525..c53be4b 100644
u32 high = divisor >> 32;
u64 quot;
diff --git a/lib/dma-debug.c b/lib/dma-debug.c
-index 4a1515f4..baea985 100644
+index 51a76af..7caf15b 100644
--- a/lib/dma-debug.c
+++ b/lib/dma-debug.c
@@ -982,7 +982,7 @@ static int dma_debug_device_change(struct notifier_block *nb, unsigned long acti
@@ -148548,7 +148548,7 @@ index 62bbf35..04d12eb 100644
struct bdi_writeback *wb = dtc->wb;
unsigned long write_bw = wb->avg_write_bandwidth;
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
-index 629ce64..c72abe5 100644
+index 1d11790..1cc6074 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -63,6 +63,7 @@
@@ -148779,7 +148779,7 @@ index 20e58e8..9045cb5 100644
struct page *page;
int ret = 0;
diff --git a/mm/rmap.c b/mm/rmap.c
-index 79f3bf0..92c8a7e 100644
+index be84cde..b9b85d9 100644
--- a/mm/rmap.c
+++ b/mm/rmap.c
@@ -172,6 +172,10 @@ int anon_vma_prepare(struct vm_area_struct *vma)
@@ -159334,7 +159334,7 @@ index 9d88c62..53396b6 100644
#define gssx_dec_release_handle NULL
#define gssx_enc_get_mic NULL
diff --git a/net/sunrpc/auth_gss/svcauth_gss.c b/net/sunrpc/auth_gss/svcauth_gss.c
-index 1095be9..815d777 100644
+index 4605dc7..c947fa5 100644
--- a/net/sunrpc/auth_gss/svcauth_gss.c
+++ b/net/sunrpc/auth_gss/svcauth_gss.c
@@ -1142,7 +1142,7 @@ static int gss_proxy_save_rsc(struct cache_detail *cd,
@@ -209776,7 +209776,7 @@ index 73a2c7d..df11b31 100644
__ksymtab_gpl 0 : { *(SORT(___ksymtab_gpl+*)) }
__ksymtab_unused 0 : { *(SORT(___ksymtab_unused+*)) }
diff --git a/scripts/package/Makefile b/scripts/package/Makefile
-index c2c7389..81b8117 100644
+index 71b4a8a..dcb89c5 100644
--- a/scripts/package/Makefile
+++ b/scripts/package/Makefile
@@ -40,7 +40,7 @@ if test "$(objtree)" != "$(srctree)"; then \
diff --git a/4.5.6/4425_grsec_remove_EI_PAX.patch b/4.5.7/4425_grsec_remove_EI_PAX.patch
index 2a1aa6c..2a1aa6c 100644
--- a/4.5.6/4425_grsec_remove_EI_PAX.patch
+++ b/4.5.7/4425_grsec_remove_EI_PAX.patch
diff --git a/4.5.6/4427_force_XATTR_PAX_tmpfs.patch b/4.5.7/4427_force_XATTR_PAX_tmpfs.patch
index aa2a091..aa2a091 100644
--- a/4.5.6/4427_force_XATTR_PAX_tmpfs.patch
+++ b/4.5.7/4427_force_XATTR_PAX_tmpfs.patch
diff --git a/4.5.6/4430_grsec-remove-localversion-grsec.patch b/4.5.7/4430_grsec-remove-localversion-grsec.patch
index 31cf878..31cf878 100644
--- a/4.5.6/4430_grsec-remove-localversion-grsec.patch
+++ b/4.5.7/4430_grsec-remove-localversion-grsec.patch
diff --git a/4.5.6/4435_grsec-mute-warnings.patch b/4.5.7/4435_grsec-mute-warnings.patch
index b7564e4..b7564e4 100644
--- a/4.5.6/4435_grsec-mute-warnings.patch
+++ b/4.5.7/4435_grsec-mute-warnings.patch
diff --git a/4.5.6/4440_grsec-remove-protected-paths.patch b/4.5.7/4440_grsec-remove-protected-paths.patch
index 741546d..741546d 100644
--- a/4.5.6/4440_grsec-remove-protected-paths.patch
+++ b/4.5.7/4440_grsec-remove-protected-paths.patch
diff --git a/4.5.6/4450_grsec-kconfig-default-gids.patch b/4.5.7/4450_grsec-kconfig-default-gids.patch
index 79a866b..79a866b 100644
--- a/4.5.6/4450_grsec-kconfig-default-gids.patch
+++ b/4.5.7/4450_grsec-kconfig-default-gids.patch
diff --git a/4.5.6/4465_selinux-avc_audit-log-curr_ip.patch b/4.5.7/4465_selinux-avc_audit-log-curr_ip.patch
index 7248385..7248385 100644
--- a/4.5.6/4465_selinux-avc_audit-log-curr_ip.patch
+++ b/4.5.7/4465_selinux-avc_audit-log-curr_ip.patch
diff --git a/4.5.6/4470_disable-compat_vdso.patch b/4.5.7/4470_disable-compat_vdso.patch
index 4aba080..4aba080 100644
--- a/4.5.6/4470_disable-compat_vdso.patch
+++ b/4.5.7/4470_disable-compat_vdso.patch
diff --git a/4.5.6/4475_emutramp_default_on.patch b/4.5.7/4475_emutramp_default_on.patch
index afd6019..afd6019 100644
--- a/4.5.6/4475_emutramp_default_on.patch
+++ b/4.5.7/4475_emutramp_default_on.patch