aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-03 19:08:09 -0800
committerDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-03 19:08:09 -0800
commitc55af00fbca986ec9e0450c0e7e215a742f82011 (patch)
tree7d37f359dbf2ea60776f27c005f3cf16d97269b5
parentAdd iab.txt which is needed for the new hwdb update. (diff)
downloadhwids-c55af00fbca986ec9e0450c0e7e215a742f82011.tar.gz
hwids-c55af00fbca986ec9e0450c0e7e215a742f82011.tar.bz2
hwids-c55af00fbca986ec9e0450c0e7e215a742f82011.zip
Use curl, with the correct settings to avoid re-fetching files.hwids-20121203
This is now critical as oui.txt and iab.txt are quite big.
-rw-r--r--Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index d21ed83..346eafe 100644
--- a/Makefile
+++ b/Makefile
@@ -1,21 +1,18 @@
-# can be replaced with `wget -q -O -` if you want
ifeq "$(V)" "0"
- HTTPCAT = curl -s
STATUS = git status -s
Q=@
else
- HTTPCAT = curl
STATUS = git status
Q=
endif
fetch:
- $(Q)$(HTTPCAT) http://pci-ids.ucw.cz/v2.2/pci.ids.bz2 | bzcat > pci.ids
- $(Q)$(HTTPCAT) http://www.linux-usb.org/usb.ids.bz2 | bzcat > usb.ids
- $(Q)$(HTTPCAT) http://standards.ieee.org/develop/regauth/oui/oui.txt > oui.txt
- $(Q)$(HTTPCAT) http://standards.ieee.org/develop/regauth/iab/iab.txt > iab.txt
- $(Q)$(HTTPCAT) http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-acpi-vendor.hwdb > udev/20-acpi-vendor.hwdb
- $(Q)$(HTTPCAT) http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl > udev-hwdb-update.pl
+ $(Q)curl -z pci.ids -o pci.ids -R http://pci-ids.ucw.cz/v2.2/pci.ids
+ $(Q)curl -z usb.ids -o usb.ids -R http://www.linux-usb.org/usb.ids
+ $(Q)curl -z oui.txt -o oui.txt -R http://standards.ieee.org/develop/regauth/oui/oui.txt
+ $(Q)curl -z iab.txt -o iab.txt -R http://standards.ieee.org/develop/regauth/iab/iab.txt
+ $(Q)curl -z udev/20-acpi-vendor.hwdb -o udev/20-acpi-vendor.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-acpi-vendor.hwdb
+ $(Q)curl -z udev-hwdb-update.pl -o udev-hwdb-update.pl -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl
$(Q)$(STATUS)
PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)