aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-25 16:30:45 +0200
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-25 16:30:45 +0200
commit0bc0d9acf0086ee3f1cccc05b8e36b6e186cd913 (patch)
tree36f6ff93404e1641b63a8bdc199142900ceb48d8
parentUpdate. (diff)
downloadhwids-0bc0d9acf0086ee3f1cccc05b8e36b6e186cd913.tar.gz
hwids-0bc0d9acf0086ee3f1cccc05b8e36b6e186cd913.tar.bz2
hwids-0bc0d9acf0086ee3f1cccc05b8e36b6e186cd913.zip
Fetch 20-net-ifname.hwdb from upstream repository. Add both 20-net-ifname.hwdb and earlier 60-keyboard.hwdb
to the date generation -line. Assuming it's the correct action to do? Main point of this commit is to include the 20-net-ifname.hwdb for >=sys-fs/udev-209 and >=sys-apps/systemd-209.
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 67c18c2..dc0c872 100644
--- a/Makefile
+++ b/Makefile
@@ -27,11 +27,12 @@ fetch:
$(Q)curl -z sdio.ids -o sdio.ids -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/sdio.ids
$(Q)curl -z udev/20-acpi-vendor.hwdb -o udev/20-acpi-vendor.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-acpi-vendor.hwdb
$(Q)curl -z udev/20-bluetooth-vendor-product.hwdb -o udev/20-bluetooth-vendor-product.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-bluetooth-vendor-product.hwdb
+ $(Q)curl -z udev/20-net-ifname.hwdb -o udev/20-net-ifname.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-net-ifname.hwdb
$(Q)curl -z udev/60-keyboard.hwdb -o udev/60-keyboard.hwdb -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/60-keyboard.hwdb
$(Q)curl -z udev-hwdb-update.pl -o udev-hwdb-update.pl -R http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl
$(Q)$(STATUS)
-PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev/20-bluetooth-vendor-product.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
+PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev/20-bluetooth-vendor-product.hwdb 20-net-ifname.hwdb 60-keyboard.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
P = hwids-$(PV)
tag: