aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-12-30 12:58:44 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-12-30 12:58:44 +0000
commit98eedf91c0f73adb4a7728dbb502f3bfe096d058 (patch)
tree86bde6b341aeb1d035311352c48e3a88c917e65c
parentEselect modules are now part of eselect-java. (diff)
downloadjava-config-98eedf91c0f73adb4a7728dbb502f3bfe096d058.tar.gz
java-config-98eedf91c0f73adb4a7728dbb502f3bfe096d058.tar.bz2
java-config-98eedf91c0f73adb4a7728dbb502f3bfe096d058.zip
Desktop files, icons, env.d and profile.d files as well as revdep-rebuild
control file and finally run-java-tool are now part of baselayout-java. Remove some java-config-1 remenmants as well. svn path=/projects/java-config-2/trunk/; revision=9131
-rw-r--r--NEWS2
-rw-r--r--config/20java-config1
-rw-r--r--config/symlink-tools16
l---------data/application-x-java-jnlp-file.png1
-rw-r--r--data/java-icon48.pngbin6855 -> 0 bytes
-rw-r--r--data/javaws.desktop12
-rw-r--r--setup.cfg43
-rw-r--r--setup.py40
-rw-r--r--src/profile.d/java-config-2.csh22
-rw-r--r--src/profile.d/java-config-2.sh34
-rw-r--r--src/revdep-rebuild/60-java9
-rw-r--r--src/run-java-tool50
12 files changed, 3 insertions, 227 deletions
diff --git a/NEWS b/NEWS
index 7a9a9a0..6f1a4b5 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,8 @@
For full ChangeLog generated from svn commit logs see ChangeLog.
* eselect modules are split-out into separate package eselect-java.
+ * desktop files, icons, env.d and profile.d files as well as revdep-rebuild
+ control file and finally run-java-tool are now part of baselayout-java.
Changes in 2.1.6:
* Fixes for virtuals that have vms as providers. Needed for for example jaf.
diff --git a/config/20java-config b/config/20java-config
deleted file mode 100644
index 1128b5d..0000000
--- a/config/20java-config
+++ /dev/null
@@ -1 +0,0 @@
-MANPATH="/etc/java-config-2/current-system-vm/man/"
diff --git a/config/symlink-tools b/config/symlink-tools
deleted file mode 100644
index e0163e8..0000000
--- a/config/symlink-tools
+++ /dev/null
@@ -1,16 +0,0 @@
-appletviewer
-apt
-jar
-jarsigner
-java
-javac
-javadoc
-javah
-javap
-javaws
-jconsole
-jdb
-keytool
-rmic
-rmid
-rmiregistry
diff --git a/data/application-x-java-jnlp-file.png b/data/application-x-java-jnlp-file.png
deleted file mode 120000
index 232f18d..0000000
--- a/data/application-x-java-jnlp-file.png
+++ /dev/null
@@ -1 +0,0 @@
-java-icon48.png \ No newline at end of file
diff --git a/data/java-icon48.png b/data/java-icon48.png
deleted file mode 100644
index 6e9648c..0000000
--- a/data/java-icon48.png
+++ /dev/null
Binary files differ
diff --git a/data/javaws.desktop b/data/javaws.desktop
deleted file mode 100644
index 1f1bdd7..0000000
--- a/data/javaws.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Java Web Start
-GenericName=Java Web Start
-Comment=Start Java Web Start applications
-Exec=javaws %u
-NoDisplay=true
-Terminal=false
-Icon=java-icon48
-MimeType=application/x-java-jnlp-file;
-Categories=Network;
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 128b813..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,43 +0,0 @@
-[install_scripts]
-symlink-tools = appletviewer
- apt
- ControlPanel
- extcheck
- HtmlConverter
- idlj
- jar
- jarsigner
- java
- javac
- javadoc
- javah
- javap
- javaws
- jconsole
- jcontrol
- jdb
- jhat
- jinfo
- jmap
- jps
- jrunscript
- jsadebugd
- jstack
- jstat
- jstatd
- jvisualvm
- keytool
- native2ascii
- orbd
- pack200
- policytool
- rmic
- rmid
- rmiregistry
- schemagen
- serialver
- servertool
- tnameserv
- wsgen
- wsimport
- xjc
diff --git a/setup.py b/setup.py
index 99f4946..d3ba2cf 100644
--- a/setup.py
+++ b/setup.py
@@ -1,39 +1,8 @@
#!/usr/bin/env python
-from distutils.command.install_scripts import install_scripts
-from distutils import log
-import os
-
-class my_install_scripts(install_scripts):
- """Specialized data file install to handle our symlinks"""
- install_scripts.user_options.append(('symlink-tools=', None,
- 'List of files to symlink to run-java-tool in script directory'))
-
- def initialize_options(self):
- install_scripts.initialize_options(self)
- self.symlink_tools = None
-
- def finalize_options(self):
- install_scripts.finalize_options(self)
- self.ensure_string_list('symlink_tools')
-
- def run(self):
- install_scripts.run(self)
- for tool in self.symlink_tools:
- s = self.install_dir + '/' + tool
- log.info("symbolically linking %s -> %s" % ('run-java-tool', s))
- if not self.dry_run:
- # os.symlink fails to overwrite existing files
- if os.path.exists(s):
- os.remove(s)
- # copy_file is not able to handle relative symlinks with --root
- os.symlink('run-java-tool', s)
-
from distutils.core import setup
-from glob import glob
setup (
- cmdclass={'install_scripts': my_install_scripts},
name = 'java-config',
version = '2.1.12',
description = 'java enviroment configuration tool',
@@ -48,18 +17,11 @@ setup (
url = 'http://www.gentoo.org',
packages = ['java_config_2'],
package_dir = { 'java_config_2' : 'src/java_config_2' },
- scripts = ['src/java-config-2','src/depend-java-query','src/run-java-tool', 'src/gjl'],
+ scripts = ['src/java-config-2','src/depend-java-query','src/gjl'],
data_files = [
- ('share/java-config-2/pym/java_config/', glob('src/java_config/*')),
- ('share/applications/', ['data/javaws.desktop']),
- ('share/icons/hicolor/48x48/mimetypes/', ['data/application-x-java-jnlp-file.png']),
- ('share/pixmaps/', ['data/java-icon48.png']),
('share/java-config-2/launcher', ['src/launcher.bash']),
('/etc/java-config-2/', ['config/virtuals']),
('/etc/java-config-2/build/', ['config/jdk.conf','config/compilers.conf']),
- ('/etc/env.d/',['config/20java-config']),
- ('/etc/profile.d/', glob('src/profile.d/*')),
- ('/etc/revdep-rebuild/', ['src/revdep-rebuild/60-java'])
]
)
diff --git a/src/profile.d/java-config-2.csh b/src/profile.d/java-config-2.csh
deleted file mode 100644
index 517a054..0000000
--- a/src/profile.d/java-config-2.csh
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.csh,v 1.3 2007/01/13 17:17:08 grobian Exp $
-
-set gentoo_user_vm = "${HOME}/.gentoo/java-config-2/current-user-vm"
-set gentoo_system_vm = "/etc/java-config-2/current-system-vm"
-
-## If we have a current-user-vm (and aren't root)... set it to JAVA_HOME
-## Otherwise set to the current system vm
-if ( ( "$uid" != "0" ) && ( -l $gentoo_user_vm ) ) then
- setenv JAVA_HOME $gentoo_user_vm
-else if ( -l $gentoo_system_vm ) then
- setenv JAVA_HOME $gentoo_system_vm
-endif
-unset gentoo_user_vm gentoo_system_vm
-
-if ( $?JAVA_HOME ) then
- # prepending to come before generation 1
- setenv MANPATH "${JAVA_HOME}/man:${MANPATH}"
- setenv JDK_HOME $JAVA_HOME
- setenv JAVAC ${JDK_HOME}/bin/javac
-endif
diff --git a/src/profile.d/java-config-2.sh b/src/profile.d/java-config-2.sh
deleted file mode 100644
index 49155d1..0000000
--- a/src/profile.d/java-config-2.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.sh-r1,v 1.1 2007/03/16 11:13:16 betelgeuse Exp $
-
-# If we have a current-user-vm (and aren't root)... set it to JAVA_HOME
-gentoo_user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
-gentoo_system_vm="/etc/java-config-2/current-system-vm"
-
-# Please make sure that this script is POSIX compliant
-# See https://bugs.gentoo.org/show_bug.cgi?id=169925
-# for more details"
-
-if [ -z "${UID}" ] ; then
- # id lives in /usr/bin which might not be mounted
- if type id >/dev/null 2>/dev/null ; then
- user_id=$(id -u)
- else
- [ "${USER}" = "root" ] && user_id=0
- fi
-fi
-
-# The root user uses the system vm
-if [ "${user_id}" != 0 -a -L "${gentoo_user_vm}" ]; then
- export JAVA_HOME=${gentoo_user_vm}
-# Otherwise set to the current system vm
-elif [ -L /etc/java-config-2/current-system-vm ]; then
- export JAVA_HOME=${gentoo_system_vm}
-fi
-
-# prepending to come before generation 1
-export MANPATH="${JAVA_HOME}/man:${MANPATH}"
-export JDK_HOME=${JAVA_HOME}
-export JAVAC=${JDK_HOME}/bin/javac
-unset gentoo_user_vm gentoo_system_vm user_id
diff --git a/src/revdep-rebuild/60-java b/src/revdep-rebuild/60-java
deleted file mode 100644
index 1aca594..0000000
--- a/src/revdep-rebuild/60-java
+++ /dev/null
@@ -1,9 +0,0 @@
-# The VM dynamically loads these at runtime so they will end up as missing
-# but actually work just fine. See for example
-# https://bugs.gentoo.org/show_bug.cgi?id=152039
-#
-# This file should only have files the are used by things like swt. If there
-# are "broken" links inside the jre itself, the jre should install it's own
-# control file.
-
-LD_LIBRARY_MASK="libjvm.so libjawt.so"
diff --git a/src/run-java-tool b/src/run-java-tool
deleted file mode 100644
index 46f804b..0000000
--- a/src/run-java-tool
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/bash
-
-user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
-system_vm="/etc/java-config-2/current-system-vm"
-# Try GENTOO_VM
-if [[ -n ${GENTOO_VM} ]]; then
- vmpath="/usr/lib/jvm/${GENTOO_VM}/"
-# Then user VM
-elif [[ -h ${user_vm} ]]; then
- vmpath=$(readlink ${user_vm})
-# And fall back to the system VM
-else
- vmpath=$(readlink ${system_vm})
-fi
-tool=$(basename $0)
-bin=${vmpath}/bin/${tool}
-jrebin=${vmpath}/jre/bin/${tool}
-
-vm_handle=$(basename ${vmpath})
-if [[ -x ${bin} ]]; then
- exec ${bin} "${@}"
-elif [[ -x ${jrebin} ]]; then
- exec ${jrebin} "${@}"
-else
- if [[ ! -d ${vmpath} ]]; then
- echo "* Home for VM '${vm_handle}' does not exist: ${vmpath}" >&2
- if [[ -n ${GENTOO_VM} ]]; then
- echo "* Invalid value for GENTOO_VM: ${GENTOO_VM}"
- elif [[ -h ${user_vm} ]]; then
- echo "* Invalid User VM: ${vm_handle}" >&2
- else
- echo "* Invalid System VM: ${vm_handle}" >&2
- fi
- else
- if [[ ${tool} = "run-java-tool" ]]; then
- echo "* run-java-tool was invoked directly" >&2
- echo "* run-java-tool should only be used via symlinks to it" >&2
- else
- echo "* ${tool} is not available for ${vm_handle} on $(uname -m)" >&2
- echo "* IMPORTANT: some Java tools are not available on some VMs on some architectures" >&2
- if (( ${EUID} != 0 )) && [[ "${DISPLAY}" ]] && type -p notify-send > /dev/null; then
- notify-send -i java-icon48 "Gentoo Java Launcher" "<b>${tool}</b> is not available for ${vm_handle}
-<a href=\"http://www.gentoo.org/doc/en/java.xml\">Gentoo Java User Guide</a>"
- fi
- fi
- fi
- exit 1
-fi
-
-