summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/kvm-init-script/files/kvm-conf.example (renamed from kvm-conf.example)0
-rw-r--r--app-emulation/kvm-init-script/files/kvm-init-script (renamed from kvm-init-script)0
-rw-r--r--[-rwxr-xr-x]app-emulation/kvm-init-script/files/qtap-manipulate (renamed from qtap-manipulate)2
-rw-r--r--app-emulation/kvm-init-script/kvm-init-script-0.1.ebuild19
-rw-r--r--metadata/layout.conf2
-rw-r--r--profiles/repo_name1
6 files changed, 24 insertions, 0 deletions
diff --git a/kvm-conf.example b/app-emulation/kvm-init-script/files/kvm-conf.example
index 46f8274..46f8274 100644
--- a/kvm-conf.example
+++ b/app-emulation/kvm-init-script/files/kvm-conf.example
diff --git a/kvm-init-script b/app-emulation/kvm-init-script/files/kvm-init-script
index 7bfeb9d..7bfeb9d 100644
--- a/kvm-init-script
+++ b/app-emulation/kvm-init-script/files/kvm-init-script
diff --git a/qtap-manipulate b/app-emulation/kvm-init-script/files/qtap-manipulate
index 09727ec..426bc78 100755..100644
--- a/qtap-manipulate
+++ b/app-emulation/kvm-init-script/files/qtap-manipulate
@@ -1,4 +1,6 @@
#!/bin/sh
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public Licens
has() {
local desired=$1 x
diff --git a/app-emulation/kvm-init-script/kvm-init-script-0.1.ebuild b/app-emulation/kvm-init-script/kvm-init-script-0.1.ebuild
new file mode 100644
index 0000000..685ec69
--- /dev/null
+++ b/app-emulation/kvm-init-script/kvm-init-script-0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EGIT_REPO_URI="git://pkgcore.org/kvm-tools"
+inherit git-2
+
+DESCRIPTION="Kvm and qemu init scripts"
+SRC_URI=''
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PDEPEND="|| ( app-emulation/qemu-kvm app-emulation/qemu )"
+
+src_install() {
+ newinitd "${FILESDIR}"/kvm-init-script kvm
+ newconfd "${FILESDIR}"/kvm-conf.example kvm.conf.example
+ newsbin "${FILESDIR}"/qtap-manipulate qtap-manipulate
+}
diff --git a/metadata/layout.conf b/metadata/layout.conf
new file mode 100644
index 0000000..ca9fee1
--- /dev/null
+++ b/metadata/layout.conf
@@ -0,0 +1,2 @@
+masters = gentoo
+thin-manifests = true
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..68ebe70
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+kvm-tools