aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
commitf32eee58b0f85fdba5be2d8bf5fff4ac54ffb155 (patch)
tree6b8106ddb025aa6adffc5a6a9c1a1e15876bd61e
parent* libvirt.pc.in: Karel pointed out the name hadn't been updated (diff)
downloadlibvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.tar.gz
libvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.tar.bz2
libvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.zip
* Makefile.am configure.in python/Makefile.am python/tests/Makefile.am
python/tests/basic.py: added first python test script and a 'make tests' target Daniel
-rw-r--r--ChangeLog6
-rw-r--r--Makefile.am7
-rw-r--r--configure.in3
-rw-r--r--python/Makefile.am7
-rw-r--r--python/tests/Makefile.am30
-rwxr-xr-xpython/tests/basic.py25
6 files changed, 77 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 43b39324a..92ea72028 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+Tue Feb 14 15:29:01 EST 2006 Daniel Veillard <veillard@redhat.com>
+
+ * Makefile.am configure.in python/Makefile.am python/tests/Makefile.am
+ python/tests/basic.py: added first python test script and
+ a 'make tests' target
+
Fri Feb 10 16:45:50 CET 2006 Daniel Veillard <veillard@redhat.com>
* libvirt.pc.in: Karel pointed out the name hadn't been updated
diff --git a/Makefile.am b/Makefile.am
index f78084052..c71ce6e32 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,3 +11,10 @@ pkgconfig_DATA = libvirt.pc
rpm: clean
@(unset CDPATH ; $(MAKE) dist && rpmbuild -ta $(distdir).tar.gz)
+
+check-local: all tests
+
+tests:
+ @(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; \
+ $(MAKE) MAKEFLAGS+=--silent tests ; fi)
+
diff --git a/configure.in b/configure.in
index f333e8a65..6982849ef 100644
--- a/configure.in
+++ b/configure.in
@@ -193,4 +193,5 @@ cp COPYING.LIB COPYING
AC_OUTPUT(Makefile src/Makefile include/Makefile docs/Makefile \
docs/examples/Makefile \
- libvirt.pc libvirt.spec include/libvirt.h python/Makefile)
+ libvirt.pc libvirt.spec include/libvirt.h \
+ python/Makefile python/tests/Makefile)
diff --git a/python/Makefile.am b/python/Makefile.am
index b0eb78ec2..a31c17da6 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -1,5 +1,7 @@
# Makefile for libvirt python library
+SUBRIRS= . tests
+
INCLUDES = \
-I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include \
@@ -60,3 +62,8 @@ $(libvirtmod_la_OBJECTS): $(GENERATED)
else
all:
endif
+
+dummy:
+
+tests test: all dummy
+ -@(cd tests && $(MAKE) MAKEFLAGS+=--silent tests)
diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
new file mode 100644
index 000000000..2391bad81
--- /dev/null
+++ b/python/tests/Makefile.am
@@ -0,0 +1,30 @@
+EXAMPLE_DIR = $(datadir)/doc/libvirt-python-$(LIBVIRT_VERSION)/examples
+
+PYTESTS= \
+ basic.py
+
+EXTRA_DIST = $(PYTESTS)
+
+if WITH_PYTHON
+tests: $(PYTESTS)
+ @echo "## running Python regression tests"
+ -@(PYTHONPATH="..:../src/.libs:$(srcdir)/../src:$$PYTHONPATH" ; \
+ export PYTHONPATH; \
+ LD_LIBRARY_PATH="$(top_builddir)/src/.libs:$$LD_LIBRARY_PATH" ; \
+ export LD_LIBRARY_PATH; \
+ for test in $(PYTESTS) ; \
+ do log=`$(PYTHON) $(srcdir)/$$test` ; \
+ if [ "`echo $$log | grep OK`" = "" ] ; then \
+ echo "-- $$test" ; echo "$$log" ; fi ; done)
+else
+tests:
+endif
+
+clean:
+ rm -f *.pyc core
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(EXAMPLE_DIR)
+ -(for test in $(PYTESTS); \
+ do @INSTALL@ -m 0644 $(srcdir)/$$test $(DESTDIR)$(EXAMPLE_DIR) ; done)
+
diff --git a/python/tests/basic.py b/python/tests/basic.py
new file mode 100755
index 000000000..a4ff4c493
--- /dev/null
+++ b/python/tests/basic.py
@@ -0,0 +1,25 @@
+#!/usr/bin/python -u
+import libvirt
+import sys
+
+conn = libvirt.openReadOnly(None)
+if conn == None:
+ print 'Failed to open connection to the hypervisor'
+ sys.exit(1)
+
+# print conn
+
+dom0 = conn.lookupByName("Domain-0")
+if dom0 == None:
+ print 'Failed to find the main domain'
+ sys.exit(1)
+
+# print dom0
+
+print "Domain 0: id %d running %s" % (dom0.ID(), dom0.OSType())
+print dom0.info()
+del dom0
+del conn
+print "OK"
+
+sys.exit(0)