summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-11-13 15:18:55 -0700
committerEric Blake <eblake@redhat.com>2010-11-24 15:23:43 -0700
commit97cde147b5ea759749119a3e1fb39403ea7d536f (patch)
tree5399294a5907cdf15fcbb26feb54743e57ce2cf3 /Makefile.am
parentbuild: enforce files.h usage (diff)
downloadlibvirt-97cde147b5ea759749119a3e1fb39403ea7d536f.tar.gz
libvirt-97cde147b5ea759749119a3e1fb39403ea7d536f.tar.bz2
libvirt-97cde147b5ea759749119a3e1fb39403ea7d536f.zip
maint: ensure syntax check exceptions are distributed
* Makefile.am (EXTRA_DIST): Factor exceptions files... (syntax_check_excpetions): into new list. Include recently added exceptions. * cfg.mk (sc_x_sc_dist_check): New check, copied from coreutils.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index bf1b49b51..bd70a3a8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,17 +14,14 @@ XML_EXAMPLES = \
$(patsubst $(srcdir)/%,%,$(wildcard $(addprefix $(srcdir)/examples/xml/, \
test/*.xml storage/*.xml)))
-EXTRA_DIST = \
- ChangeLog-old \
- libvirt.spec libvirt.spec.in \
- mingw32-libvirt.spec.in \
- libvirt.pc libvirt.pc.in \
- autobuild.sh \
+syntax_check_exceptions = \
.x-sc_avoid_ctype_macros \
.x-sc_avoid_if_before_free \
.x-sc_avoid_write \
.x-sc_bindtextdomain \
.x-sc_m4_quote_check \
+ .x-sc_po_check \
+ .x-sc_prohibit_always_true_header_tests \
.x-sc_prohibit_asprintf \
.x-sc_prohibit_close \
.x-sc_prohibit_empty_lines_at_EOF \
@@ -34,6 +31,7 @@ EXTRA_DIST = \
.x-sc_prohibit_have_config_h \
.x-sc_prohibit_HAVE_MBRTOWC \
.x-sc_prohibit_nonreentrant \
+ .x-sc_prohibit_readlink \
.x-sc_prohibit_sprintf \
.x-sc_prohibit_strcmp \
.x-sc_prohibit_strncmp \
@@ -43,9 +41,18 @@ EXTRA_DIST = \
.x-sc_require_config_h \
.x-sc_require_config_h_first \
.x-sc_trailing_blank \
+ .x-sc_unmarked_diagnostics
+
+EXTRA_DIST = \
+ ChangeLog-old \
+ libvirt.spec libvirt.spec.in \
+ mingw32-libvirt.spec.in \
+ libvirt.pc libvirt.pc.in \
+ autobuild.sh \
Makefile.nonreentrant \
autogen.sh \
examples/domain-events/events-python \
+ $(syntax_check_exceptions) \
$(XML_EXAMPLES)
pkgconfigdir = $(libdir)/pkgconfig