aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-05-09 13:46:09 +0000
committerJim Meyering <meyering@redhat.com>2008-05-09 13:46:09 +0000
commit82892f131b83746e6359845d2de39369728f8c25 (patch)
tree106ed900c720b541c148985c76f86fa7d4314768 /build-aux
parentautostart for running Xen domains (diff)
downloadlibvirt-82892f131b83746e6359845d2de39369728f8c25.tar.gz
libvirt-82892f131b83746e6359845d2de39369728f8c25.tar.bz2
libvirt-82892f131b83746e6359845d2de39369728f8c25.zip
Prepare to use gnulib's c-type module.
* bootstrap: Move module list into separate variable w/less syntax. (modules): Add c-ctype. Update the following from gnulib: * build-aux/useless-if-before-free: * build-aux/vc-list-files: * gnulib/lib/Makefile.am: * gnulib/lib/getaddrinfo.h: * gnulib/m4/gnulib-cache.m4: * gnulib/m4/gnulib-comp.m4: * gnulib/m4/inet_ntop.m4: * gnulib/tests/Makefile.am: * gnulib/tests/test-getaddrinfo.c:
Diffstat (limited to 'build-aux')
-rwxr-xr-xbuild-aux/useless-if-before-free6
-rwxr-xr-xbuild-aux/vc-list-files4
2 files changed, 5 insertions, 5 deletions
diff --git a/build-aux/useless-if-before-free b/build-aux/useless-if-before-free
index 4603c6c60..48f55c661 100755
--- a/build-aux/useless-if-before-free
+++ b/build-aux/useless-if-before-free
@@ -2,7 +2,7 @@
# Detect instances of "if (p) free (p);".
# Likewise for "if (p != NULL) free (p);". And with braces.
-my $VERSION = '2008-04-29 19:56'; # UTC
+my $VERSION = '2008-05-01 19:11'; # UTC
# The definition above must lie within the first 8 lines in order
# for the Emacs time-stamp write hook (at end) to update it.
# If you change this file with Emacs, please let the write hook
@@ -68,8 +68,8 @@ OPTIONS:
Exit status:
- 0 no match
- 1 one or more matches
+ 0 one or more matches
+ 1 no match
2 an error
EXAMPLE:
diff --git a/build-aux/vc-list-files b/build-aux/vc-list-files
index abb0c4023..8ca4530f7 100755
--- a/build-aux/vc-list-files
+++ b/build-aux/vc-list-files
@@ -2,7 +2,7 @@
# List version-controlled file names.
# Print a version string.
-scriptversion=2008-04-30.12
+scriptversion=2008-05-01.10
# Copyright (C) 2006-2008 Free Software Foundation, Inc.
@@ -91,7 +91,7 @@ elif test -d CVS; then
sub(/CVS\/Entries/, "", f); \
print f $2; \
}}'\'' \
- $(find "$dir" -name Entries -print) /dev/null' $postprocess
+ `find "$dir" -name Entries -print` /dev/null' $postprocess
fi
else
echo "$0: Failed to determine type of version control used in `pwd`" 1>&2