aboutsummaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
authorMatthias Bolte <matthias.bolte@googlemail.com>2011-07-19 14:16:47 +0200
committerMatthias Bolte <matthias.bolte@googlemail.com>2011-07-21 17:00:59 +0200
commitfbd5465a5b5ab6e635d782595b1a3b570138003b (patch)
tree68520150e2920da683bbddc0e2618e81535fe38d /daemon
parenterror: preserve errno when saving last error (diff)
downloadlibvirt-fbd5465a5b5ab6e635d782595b1a3b570138003b.tar.gz
libvirt-fbd5465a5b5ab6e635d782595b1a3b570138003b.tar.bz2
libvirt-fbd5465a5b5ab6e635d782595b1a3b570138003b.zip
rpc: Make the dispatch generator handle 'void name(void)' style procedures
The only 'void name(void)' style procedure in the protocol is 'close' that is handled special, but also programming errors like a missing _args or _ret suffix on the structs in the .x files can create such a situation by accident. Making the generator aware of this avoids bogus errors from the generator such as: Use of uninitialized value in exists at ./rpc/gendispatch.pl line 967. Also this allows to get rid of the -c option and the special case code for the 'close' procedure, as the generator handles it now correctly. Reported by Michal Privoznik
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 8ed29b89e..63c731efb 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -44,7 +44,7 @@ QEMU_PROTOCOL = $(top_srcdir)/src/remote/qemu_protocol.x
$(srcdir)/remote_dispatch.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -c -b remote \
+ $(AM_V_GEN)perl -w $(srcdir)/../src/rpc/gendispatch.pl -b remote \
$(REMOTE_PROTOCOL) > $@
$(srcdir)/qemu_dispatch.h: $(srcdir)/../src/rpc/gendispatch.pl \