summaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-12-05 10:14:55 -0700
committerEric Blake <eblake@redhat.com>2011-12-05 10:14:55 -0700
commitf17e0e2182ecefd9ba9eb346bab839cd5b59fb9c (patch)
tree1f57be5d5f372182d90d79e2e23bcd8333bfacbf /m4
parentexamples: Update event tests for shutdown event (diff)
downloadlibvirt-f17e0e2182ecefd9ba9eb346bab839cd5b59fb9c.tar.gz
libvirt-f17e0e2182ecefd9ba9eb346bab839cd5b59fb9c.tar.bz2
libvirt-f17e0e2182ecefd9ba9eb346bab839cd5b59fb9c.zip
build: reduce warnings from older gcc
Older gcc warns (on every file!) that -Wabi and -Wdeprecated only make sense on C++ projects. Newer gcc accepts these warnings for C, but it is not clear that they can do anything useful, so it is easier to just drop the warnings altogether. * m4/virt-compile-warnings.m4 (LIBVIRT_COMPILE_WARNINGS): Silence -Wabi and -Wdeprecated on older gcc. Reported by Peter Krempa.
Diffstat (limited to 'm4')
-rw-r--r--m4/virt-compile-warnings.m42
1 files changed, 2 insertions, 0 deletions
diff --git a/m4/virt-compile-warnings.m4 b/m4/virt-compile-warnings.m4
index a17e4b764..ba388aad1 100644
--- a/m4/virt-compile-warnings.m4
+++ b/m4/virt-compile-warnings.m4
@@ -22,6 +22,8 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
# Don't care about C++ compiler compat
dontwarn="$dontwarn -Wc++-compat"
+ dontwarn="$dontwarn -Wabi"
+ dontwarn="$dontwarn -Wdeprecated"
# Don't care about ancient C standard compat
dontwarn="$dontwarn -Wtraditional"
# Don't care about ancient C standard compat