aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Bolte <matthias.bolte@googlemail.com>2011-07-21 13:45:42 +0200
committerMatthias Bolte <matthias.bolte@googlemail.com>2011-07-21 14:36:34 +0200
commit1468359f16b7b52c7ed815b2cb7af07762ca011a (patch)
tree1b8a8cf48fa55e5caff33e11ad85282b4af1c402 /python/Makefile.am
parentFix uninitialized variable in QEMU CPU bandwidth code (diff)
downloadlibvirt-1468359f16b7b52c7ed815b2cb7af07762ca011a.tar.gz
libvirt-1468359f16b7b52c7ed815b2cb7af07762ca011a.tar.bz2
libvirt-1468359f16b7b52c7ed815b2cb7af07762ca011a.zip
python: Fix makefile rule for code generation
Commit 8665f85523f0451c changed generated.stamp to $(GENERATE).stamp, but missed one instance in the CLEANFILES list. This can break the build in case the generated code is deleted but the .stamp file stays around and therefore the code isn't regenerated.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index a4c9a6b2c..51f005db4 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -71,7 +71,7 @@ install-data-local:
uninstall-local:
rm -f $(DESTDIR)$(pyexecdir)/libvirt.py
-CLEANFILES= $(GENERATED) generated.stamp
+CLEANFILES= $(GENERATED) $(GENERATE).stamp
else
all: