aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-28 12:17:00 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-28 12:17:00 +0000
commit65bace1765c388e95f7317d4a6dc876537d7510c (patch)
tree77c93b55c643cdf33206e81e6054225b57632f02 /python/Makefile.am
parent* doc//*: rebuilt (diff)
downloadlibvirt-65bace1765c388e95f7317d4a6dc876537d7510c.tar.gz
libvirt-65bace1765c388e95f7317d4a6dc876537d7510c.tar.bz2
libvirt-65bace1765c388e95f7317d4a6dc876537d7510c.zip
* TODO: updated
* python/Makefile.am python/generator.py python/libvir.c python/libvir.py: improved python binding, raise exception when an instance creation or lookup fails, and add support for the global error handler, per conn handler still needed * python/tests/error.py python/tests/Makefile.am: adding a regression test Daniel
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index c57b9f7e6..96865a44d 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -18,6 +18,7 @@ EXTRA_DIST = \
generator.py \
libvirt_wrap.h \
libvirt.py \
+ libvir.py \
libvirt-python-api.xml \
$(DOCS)
@@ -33,6 +34,8 @@ python_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvir.c types.c libvirt-py.c libvirt-py.h
libvirtmod_la_LIBADD = $(mylibs)
+libvirt.py: $(srcdir)/libvir.py libvirtclass.py
+ cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(pythondir)