aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-05-31 16:15:28 -0600
committerEric Blake <eblake@redhat.com>2011-07-01 10:44:17 -0600
commit6ae3052c06cd97b00f99790cb95fc7f11971e985 (patch)
treeff83f040d2f300f6743f154915591c6523dd4786 /python/Makefile.am
parentExplicitely invoke python for API doc generator (diff)
downloadlibvirt-6ae3052c06cd97b00f99790cb95fc7f11971e985.tar.gz
libvirt-6ae3052c06cd97b00f99790cb95fc7f11971e985.tar.bz2
libvirt-6ae3052c06cd97b00f99790cb95fc7f11971e985.zip
build: consistently use CFLAGS
According to the automake manual, CPPFLAGS (aka INCLUDES, as spelled in automake 1.9.6) should only include -I, -D, and -U directives; more generic directives like -Wall belong in CFLAGS since they affect more phases of the build process. Therefore, we should be sticking CFLAGS additions into a CFLAGS container, not a CPPFLAGS container. * src/Makefile.am (libvirt_driver_vmware_la_CFLAGS): Use AM_CFLAGS. (INCLUDES): Move CFLAGS items... (AM_CFLAGS): ...to their proper location. * python/Makefile.am (INCLUDES, AM_CFLAGS): Likewise. * tests/Makefile.am (INCLUDES, AM_CFLAGS): Likewise. (commandtest_CFLAGS, commandhelper_CFLAGS) (virnetmessagetest_CFLAGS, virnetsockettest_CFLAGS): Use AM_CFLAGS.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 432ad7091..0edb3e4cb 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -3,12 +3,13 @@
SUBDIRS= . tests
INCLUDES = \
- $(WARN_CFLAGS) \
- $(PYTHON_INCLUDES) \
+ $(PYTHON_INCLUDES) \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
-I$(top_builddir)/$(subdir)
+AM_CFLAGS = $(WARN_CFLAGS)
+
DOCS_DIR = $(datadir)/doc/libvirt-python-$(LIBVIRT_VERSION)
DOCS = ${srcdir}/TODO