aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2007-03-06 21:55:44 +0000
committerDaniel P. Berrange <berrange@redhat.com>2007-03-06 21:55:44 +0000
commitd6db609d74373508d1006961bd77fe8651b9ba3f (patch)
treed3abb594903aea6c474916eac298831f69150e96 /python/Makefile.am
parentAdded support for keymap in VNC display (diff)
downloadlibvirt-d6db609d74373508d1006961bd77fe8651b9ba3f.tar.gz
libvirt-d6db609d74373508d1006961bd77fe8651b9ba3f.tar.bz2
libvirt-d6db609d74373508d1006961bd77fe8651b9ba3f.zip
Fixed up numerous compiler warnings
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index d8ffd149e..dbb471d30 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -33,7 +33,9 @@ all-local: libvirt.py
python_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvir.c types.c libvirt-py.c libvirt-py.h
-libvirtmod_la_LIBADD = $(mylibs)
+libvirtmod_la_LIBADD = $(mylibs)
+# Python header files contain a redundant decl, hence:
+libvirtmod_la_CFLAGS = -Wno-redundant-decls
libvirt.py: $(srcdir)/libvir.py libvirtclass.py
cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py