aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2012-02-07 13:30:42 +0100
committerMichal Privoznik <mprivozn@redhat.com>2012-02-07 13:30:42 +0100
commitf2445e4de70547e32a6bcec3e1e8e51f02ac5b36 (patch)
treeabbae08920719b0c63b49bb2d2dafee2bdae1448 /python/Makefile.am
parentbuild: avoid gcc 4.7 warning about inlines (diff)
downloadlibvirt-f2445e4de70547e32a6bcec3e1e8e51f02ac5b36.tar.gz
libvirt-f2445e4de70547e32a6bcec3e1e8e51f02ac5b36.tar.bz2
libvirt-f2445e4de70547e32a6bcec3e1e8e51f02ac5b36.zip
pyhton: Don't link against libvirt_util.la
As we already link with libvirt.la which contains libvirt_utils.la. Double linking causes global symbols to be presented twice and thus confusion. This partially reverts c700613b8d463212d142c97108b7a2352e23e559
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 9b791d77c..0305bcccd 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -41,11 +41,9 @@ EXTRA_DIST = \
if WITH_PYTHON
mylibs = \
$(top_builddir)/src/libvirt.la \
- $(top_builddir)/src/libvirt_util.la \
$(top_builddir)/gnulib/lib/libgnu.la
myqemulibs = \
$(top_builddir)/src/libvirt-qemu.la \
- $(top_builddir)/src/libvirt_util.la \
$(top_builddir)/gnulib/lib/libgnu.la
all-local: libvirt.py libvirt_qemu.py