aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
commitf32eee58b0f85fdba5be2d8bf5fff4ac54ffb155 (patch)
tree6b8106ddb025aa6adffc5a6a9c1a1e15876bd61e /python/Makefile.am
parent* libvirt.pc.in: Karel pointed out the name hadn't been updated (diff)
downloadlibvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.tar.gz
libvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.tar.bz2
libvirt-f32eee58b0f85fdba5be2d8bf5fff4ac54ffb155.zip
* Makefile.am configure.in python/Makefile.am python/tests/Makefile.am
python/tests/basic.py: added first python test script and a 'make tests' target Daniel
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index b0eb78ec2..a31c17da6 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -1,5 +1,7 @@
# Makefile for libvirt python library
+SUBRIRS= . tests
+
INCLUDES = \
-I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include \
@@ -60,3 +62,8 @@ $(libvirtmod_la_OBJECTS): $(GENERATED)
else
all:
endif
+
+dummy:
+
+tests test: all dummy
+ -@(cd tests && $(MAKE) MAKEFLAGS+=--silent tests)