aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-06-09 09:55:36 -0600
committerEric Blake <eblake@redhat.com>2012-06-19 13:50:03 -0600
commitf73d99c2a5bf7bf54c67294ad40eca3c79327665 (patch)
treeaf2b5a4d209c9eb4ce0dbc76180e51e81b2eb1b9 /python/Makefile.am
parentlist: use the new snapshot API in virsh when possible (diff)
downloadlibvirt-f73d99c2a5bf7bf54c67294ad40eca3c79327665.tar.gz
libvirt-f73d99c2a5bf7bf54c67294ad40eca3c79327665.tar.bz2
libvirt-f73d99c2a5bf7bf54c67294ad40eca3c79327665.zip
list: provide python bindings for snapshots
This adds support for the new virDomainListAllSnapshots (a domain function) and virDomainSnapshotListAllChildren (a snapshot function) to the libvirt-python bindings. The implementation is done manually as the generator does not support wrapping lists of C pointers into python objects. * python/libvirt-override.c (libvirt_virDomainListAllSnapshots) (libvirt_virDomainSnapshotListAllChildren): New functions. * python/libvirt-override-api.xml: Document them. * python/libvirt-override-virDomain.py (listAllSnapshots): New file. * python/libvirt-override-virDomainSnapshot.py (listAllChildren): Likewise. * python/Makefile.am (CLASSES_EXTRA): Ship them.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 02b59eb2d..97f21c387 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -24,6 +24,8 @@ DOCS = ${srcdir}/TODO
CLASSES_EXTRA = \
libvirt-override-virConnect.py \
+ libvirt-override-virDomain.py \
+ libvirt-override-virDomainSnapshot.py \
libvirt-override-virStream.py
EXTRA_DIST = \