aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Krempa <pkrempa@redhat.com>2012-06-05 14:00:52 +0200
committerPeter Krempa <pkrempa@redhat.com>2012-06-18 21:24:13 +0200
commit2c6808044408fba9ff9547ad88bb8a0f44ee21a0 (patch)
treee0352b26d38843297c8e4d47efdf6881149df150 /src/Makefile.am
parentconf: Store managed save image existence in virDomainObj (diff)
downloadlibvirt-2c6808044408fba9ff9547ad88bb8a0f44ee21a0.tar.gz
libvirt-2c6808044408fba9ff9547ad88bb8a0f44ee21a0.tar.bz2
libvirt-2c6808044408fba9ff9547ad88bb8a0f44ee21a0.zip
conf: Add helper for listing domains on drivers supporting virDomainObj
This patch adds common code to list domains in fashion used by virListAllDomains with all currently supported flags. The header file also contains macros that group filters together that are used to shorten filter conditions.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2bcebcfb2..e40909bbb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -190,10 +190,15 @@ ENCRYPTION_CONF_SOURCES = \
CPU_CONF_SOURCES = \
conf/cpu_conf.c conf/cpu_conf.h
+
# Safe console handling helper APIs
CONSOLE_CONF_SOURCES = \
conf/virconsole.c conf/virconsole.h
+# Domain listing helpers
+DOMAIN_LIST_SOURCES = \
+ conf/virdomainlist.c conf/virdomainlist.h
+
CONF_SOURCES = \
$(NETDEV_CONF_SOURCES) \
$(DOMAIN_CONF_SOURCES) \
@@ -206,7 +211,8 @@ CONF_SOURCES = \
$(INTERFACE_CONF_SOURCES) \
$(SECRET_CONF_SOURCES) \
$(CPU_CONF_SOURCES) \
- $(CONSOLE_CONF_SOURCES)
+ $(CONSOLE_CONF_SOURCES) \
+ $(DOMAIN_LIST_SOURCES)
# The remote RPC driver, covering domains, storage, networks, etc
REMOTE_DRIVER_GENERATED = \